19

I found that some of my keyboard shortcuts somehow trigger open office 365 welcome window. I'm a heavy autohotkey user and it looks like it have something to do with alt+shift. I tried to remove office alltogether, but then new window in chrome spawns on keyboard shortcut suggesting me to buy office. Can I remove it somehow?

P.S. Here's the link to popup: https://www.office.com/?from=OfficeKey As you can see, from option is set to "OfficeKey". What is this OfficeKey then and how to change it or better completely remove?

P.P.S. As described here: https://www.theverge.com/2019/6/18/18683333/microsoft-office-key-keyboards-support it is added recently, and it looks like the reason in that I'm on developers edition of windows 10 with latest updates.

Here's the screenshot of browser popup: enter image description here

7
  • Is it possible that you have installed Office trial and now cannot get rid of the request for buying a serial? – harrymc Jul 4 '19 at 17:20
  • no, its only triggered when I press specific keboard shortcuts like alt + shift + l for some reason – sandric Jul 4 '19 at 17:41
  • Please add a screenshot of that windows. – harrymc Jul 4 '19 at 17:42
  • @harrymc added in description. – sandric Jul 4 '19 at 17:47
  • Alt+shift is used for switching input languages. If you only have one input language you can disable it. – harrymc Jul 4 '19 at 17:59
32

Just upgraded to Windows 1903 and hit this myself, seems Microsoft decided to assign the keyboard shortcut for the new Office App to Win+Ctrl+Alt+Shift! (aka HYPR key combination for QMK users)

Changing the open command for this keyboard shortcut to rundll32 resolved the issue for me. Using an elevated cmd, run the following command:

    REG ADD HKCU\Software\Classes\ms-officeapp\Shell\Open\Command /t REG_SZ /d rundll32
1
  • 1
    This did not work for me. For example, pressing Win+Ctrl+Alt+Shift+L still takes me to LinkedIn. – aardvarkk Sep 22 '20 at 22:13
1

jfrmilner's answer works, but doesn't disable the application-specific hotkeys.

How to Remap the Office Key on Your Keyboard.

OfficeKeyFix-

It involves restarting Explorer, so it's not pretty, but it is a fix.

0

For AHK:

^!+LWin::send {Blind}{vk07}

It keeps the OfficeKey + letter hotkeys in place. You can add your own:

^!+#m::run explorer.exe shell:AppsFolder\microsoft.windowscommunicationsapps_8wekyb3d8bbwe!microsoft.windowslive.mail
^!+#c::run explorer.exe shell:AppsFolder\microsoft.windowscommunicationsapps_8wekyb3d8bbwe!microsoft.windowslive.calendar

If you have installed the Microsoft Office app from the Microsoft Store, this app will open instead of the website. If you still want to be able to use the app sometimes and it's installed, you can map it to OfficeKey + Enter for example:

^!+#Enter::run explorer.exe shell:AppsFolder\Microsoft.MicrosoftOfficeHub_8wekyb3d8bbwe!Microsoft.MicrosoftOfficeHub
-1
  • locate OneDrive icon somewhere
  • right click item
  • "Settings"
  • "Office" tab
  • uncheck "Use Office applications to sync Office files that I open"

:)

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.