1

Added chinese(simplified) keyboard layout in windows 10, and by default after reboot chinese keyboard layout will enabled for all applications. Internally, chinese keyboard has Key combination CTRL+Shift to switch between english and chinese (Pinyin).

The problem here is the key Shift from Hardware keyboard also works as language switch from chinese.

i.e. it disables the chinese IME

Please help, how to stop this behavior?

1

While in the Chinese Input Method, pressing Shift will switch between Chinese mode and English mode, which is undesirable for some people.

This behavior can be changed in Windows 10 as follows:

  • Open Settings > Time & Language > Language
  • Under Preferred languages, select your Chinese flavor
  • Once expanded, click Options
  • Under Keyboards, select your input method (ChangJie / Quick / PinYin / etc.)
  • (Here is where I'm running blind:) You should have a Mode Change Key or Mode Switching or similar. Change "Shift" to "None".

Here is a screenshot I located on the Internet, as I'm not using Chinese:

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.