0

I am using Microsoft Office 365 ProPlus. When I save my document as CSV, I end up with values separated with semi-colons, but I really need commas.

I tried changing Windows Regional Settings to put a different list separator, but excel doesn't take it.

Also, when I do a Save As, I have two choices of CSV in the drop down (comma or semi-colon separator) but both end up with semi-colons as the separator.

How do I fix this? (please don't ask me to do a search and replace...)

  • AFAIK, that separator is, indeed, dependent on the list separator in the Windows Regional Settings. On the Numbers tab under Additional Settings. Are you sure you hit Apply or closed the dialog box, after typing in the comma as the list separator? – Ron Rosenfeld Jul 5 '19 at 20:05
0

Try this advice:

 Select File -> Options -> Advanced. Clear the check box 'Use system
 settings'.

 Set 'Decimal separator' to a point (dot), and 'Thousands separator' to
 a comma. Click OK.

 Export to CSV.

 Select File -> Options -> Advanced. Tick the check box 'Use system
 settings'. Click OK
  • no luck, still semi-colons... – Philippe Jul 5 '19 at 13:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.