3

I have enabled Hyper-V on my Windows 10 Pro (v.1809) and installed Ubuntu-v18.04.2-64bit Desktop image. In Hyper-V Manager, I have been getting this error when connecting to the virtual machine:

Video remoting was disconnected unexpectedly

But from this screen I think it was started successfully:

Ubuntu 18.04.2 running screen

I have tried many solutions but none of them work for me:

  1. Enable RemoteFX
  2. Disable enhanced session mode

I try to start all Hyper-V related services but only the following ones can be started: HV Host Service, Host Computer Service, Virtual Machine Management.

The running Hyper-v related services

I also find this error showing up when connection failed in Event Viewer > Hyper-V-VMMS log:

*The Hyper-V Virtual Machine Management service encountered an unexpected error: Unspecified error (0x80004005).*
  • Check if all HyperV related services are running in Service Manager (services.msc)? – Biswapriyo Jul 6 '19 at 3:59
  • Thank you. I just updated my description. – enix0907 Jul 6 '19 at 18:36
  • Personally, if I see any error having "unexpected error" message in Windows 10, I just clean install it. – Biswapriyo Jul 6 '19 at 19:05
  • Ok I will uninstall Hyper-V and install it. Hopefully the issue will be solved. Thanks. – enix0907 Jul 6 '19 at 20:29
  • No luck. Still getting the same error. I start to wonder if this is something to do with my hardware/drivers? maybe it's my network or video card? or 4K resolution? – enix0907 Jul 6 '19 at 23:50
1

I have the exact same problem. For now I solved by disabling the enhanced session mode in the Hyper-V configuration. But different from you I disabled in the USER section and not in the SERVER section and works for me. I hope this can help

| improve this answer | |
2

I had the same problem and I could use the machine with the enhanced session mode turned off, but this gives the limited usability.

The problem was that I set up the Ubuntu machine to log me in automatically. When I set it up to "Require password", I can use the enhanced mode.

| improve this answer | |
  • Auto login was the problem for me as well – jacob_pro Apr 13 at 15:57
0

Enhanced session mode can allow dynamic resolution and better user experience but you must disable the auto login when connecting in enhanced session mode.

You can login via the basic mode first: - select "view" from the toolbar - uncheck the "Enhanced session"

Now, you should be able to login in its default solution. You can go to setting -> account and disable the auto login.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.