0

I have been upgrading a pretty battered x230 - coreboot and me_cleaner, new ssd, more ram. Now I think - maybe - I've damaged the motherboard.

(This is Lubuntu on 18.10, but also tried on 18.04.02, Fedora, Manjaro live usbs)

I've lost all connectivity - it sees wifi, but will not connect; usb tethering, will not connect; pc-to-pc ethernet (its the only other thing I've got, I use a phone hotspot) registers the connection, but stays disconnected. (Terminal outputs at this reddit post).

I haven't really tried to do much other than terminal and launch a browser, but otherwise the device seems to work just fine except for RTC.

A couple of error messages during bootup (I [i]think[/i] they are new):

[ 7.468462] rtc_cmos 00:03: hctosys: unable to read the hardware clock

[ 9.599416] sd 6:0:0:0: [sdb] No Caching mode page found

[ 9.599462] sd 6:0:0:0: [sdb] Assuming drive cache: write through

Also, from terminal

$ sudo hwclock -r --verbose [sudo] password for x: hwclock from util-linux 2.32 System Time: 4450569161.785350 Trying to open: /dev/rtc0 Using the rtc interface to the clock. Last drift adjustment done at 1542504706 seconds after 1969 Last calibration done at 1542504706 seconds after 1969 Hardware clock is on UTC time Assuming hardware clock is kept in UTC time. Waiting for clock tick... ioctl(4, RTC_UIE_ON, 0): Invalid argument Waiting in loop for time from /dev/rtc0 to change hwclock: ioctl(RTC_RD_TIME) to /dev/rtc0 to read the time failed: Invalid argument ...synchronisation failed

So, does networking require RTC (any accessible references you could recommend?), or is this a different malfunction? Assuming I don't need to replace a CMOS battery that has suddenly and catastrophically failed, (how likely would that be?), is there a fix?

Its frustrating that there is an otherwise perfectly functioning board here. Worst come to worst, any bright ideas for a computer that is effectively airgapped?

  • Does the problem occur with original firmware? – grawity Jul 6 at 9:42
  • No, it was fine. But it was also fine for several weeks on coreboot/seabios and me_cleaner. It really was that final reassembly (I replaced the thermal paste) that seemed to trigger the problem. – j doe will do just fine Jul 6 at 11:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.