1

I have a windows 10 enterprise system. The screen keeps timing out and displaying the lock screen after 20 minutes. I am both local and domain administrator. I've disabled the screensaver in the registry both in HKCU and HKU. Gpedit shows Enable Screen Saver is set to no. The screen saver options menu shows a screensaver of "none" and a timeout of 20 minutes, despite the fact that I've edited the registry to disable the timeout. The power settings are configured appropriately - the system is not sleeping, the screensaver is just activating for some reason.

Is there another key besides the ones in HKCU/Control Panel/Desktop and HKU/.DEFAULT/Control Panel/Desktop that I need to fiddle with to truly break the screensaver once and for all?

  • Does there exist a registry key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Personalization and in it a DWORD item named NoLockScreen? If not, create it with the value of 1. – harrymc Jul 8 '19 at 14:30
0

Setting the local group policy ought to do the trick:

  1. Run GPEDIT.MSC locally
  2. Navigate to User ConfigurationAdministrative TemplatesControl PanelPersonalization
  3. Set 'Enable Screen Saver' to 'Disabled'
  4. Reboot
  • It does not. There seems to be a lingering setting somewhere. – Olylo Jul 8 '19 at 14:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.