2

I've been fiddling with my anaconda, jupyter, IPython installations, and I honestly don't know how I ended up with this error. Can anyone help me resolve this so I can get back to running jupyter notebooks with Python 3.x?

[C 17:01:34.358 NotebookApp] Bad config encountered during initialization:
[C 17:01:34.359 NotebookApp] The 'contents_manager_class' trait of <notebook.notebookapp.NotebookApp object at 0x1016caa90> instance must be a type, but 'jupytext.TextFileContentsManager' could not be imported

Thanks!

2

The issue was a bad config file that got in there somehow. This answer https://github.com/jupyter/notebook/issues/274 helped me resolve the problem. I had to go to the folder path that was returned when I ran the following command

jupyter --config-dir

I removed all files in this folder and ran

jupyter notebook

and this opened the jupyter notebook normally.

  • This worked well, Thanks Abel!! – Itachi Aug 7 '19 at 8:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.