0

My MacBook needs to be updated and tells me, that it needs 17GB of available disk space. I deleted many files and "About my Mac" shows that there are 50+GB available. About this Mac shows 50+GB of available space But the message that there is not enough space for the update still appears. However, Disk Utility shows only 10GB available.Disk Utility shows only 10GB of available space I ran First Aid, but it could not offer a solution to my problem. It tells me, that there is an error, but it needs to be solved in recovery.Disk Utility tells me, that there is something wrong with the disk What is pretty suspicious is the fact, that Disk Utility shows my disk twice in the sidebar, both with only 10GB available, but the error appears only on the first one, although it is one and the same disk.This is the same disk, but it shows different usage and no error message in First Aid I booted into recovery, ran First Aid, and suddenly no errors showed up. Still, when I boot normally, Disk Utility shows 10GB and the error again and "About my Mac" shows the 50+GB again. Nevertheless I cannot install the update, since macOS requires 17GB of free space to install it.

1

I'm assuming that's Catalina beta - it sets up a new 'data' drive, separate from the boot partition.

Your issue isn't the two apparent volumes, it's the amount of purgeable space.

About this Mac doesn't display the purgeable at all. Disk Utility does.
If you subtract the Purgeable from the Available they will then agree.

As far as the update is concerned, it's not going to purge the purgeable to do this; so you'll need to do it manually, or otherwise slim down the drive some more.

Slimming your local Time Machine data might be sufficient.
First connect your Time Machine drive & manually Back Up Now.
Then, in terminal, type tmutil thinlocalsnapshots / 1000000000000 1
This will aggressively clean up old local backups.
Check your available - purgeable again afterwards.

If that's not sufficient, the only real way to purge the purgeable is to fill the drive with big files then delete them.

|improve this answer|||||
  • Awesome solution! I had the same issue on macOS 10.13.6 High Sierra and I couldn't work out what was wrong. This did the trick, thank you for sharing. – Jay Versluis Mar 11 at 3:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.