When i tried to execute docker quickstart terminal .

it showed following message

"This computer doesn't have VT-X/AMD-v enabled. Enabling it in the BIOS is mandatory"

But my PC already Enabled Virtualization. i checked "bios setting" and "task manager -> performance"

I am using Windows Home + AMD CPU

How can i solve this


Windows 10 Home (Ver. 1803, OS build 17134.829)

I am only using window defender

Docker toolbox includes Oracle VM VirtualBox, so Oralce VM VirtualBox was installed with docker

Strange thing is that i am using App player

I think it is using VT

  • 1
    What version of Windows 10 do you have installed? Please edit your question to include the output of winver What security software do you have installed? Many AV products have hardware virtualization features, when installed on a system, this prevent Docker (and other similar products) from using the hardware virtalization (VT-x or AMD-V) – Ramhound Jul 9 '19 at 14:19
  • 1
    What version of VirtualBox do you have installed? This is a requirement since you have an AMD processor and are not running Windows 10 Professional. – Ramhound Jul 9 '19 at 18:06
Open the Window Start Menu
Search for “CMD”
Right-click on “CMD” and click on “Run as Administrator”
Enter and run bcdedit /set hypervisorlaunchtype off
Restart your PC

Here is a externel link with the almost the same problem solved - check it out https://github.com/docker/machine/issues/4271

  • The author is using Windows 10 Home, which does not support Hyper-V, the command you are suggesting disables Hypervisor support. The command does not apply to Windows 10 Home. – Ramhound Jul 9 '19 at 17:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.