1

I have a 2-years old 1st Generation Lenovo Thinkpad 13, running Ubuntu.

Its battery does not charge anymore; when I plug the AC, I can use the laptop perfectly, and it shows "charging", but the percentage does not move (6% at the moment). Replacing the battery and the power supply did not solve the problem.

I tried the "power reset" thing (as explained here in Fix 2, and I also tried to Disable built-in battery in the BIOS/firmware with no success.

How may I solve this?

Rk: the model number is 20GJ-CT01WW

5
  • 1
    Take it to a repair shop.
    – DavidPostill
    Jul 9, 2019 at 15:42
  • I did but the guy thought that was the battery - and he told me he could not buy me one with the people he knew (no stock). So I did it by myself (buy a new battery) and, well, this still does not work!
    – Clem.
    Jul 9, 2019 at 15:44
  • 4
    Yeah, well it could be the charging circuit. Go find another repair shop.
    – DavidPostill
    Jul 9, 2019 at 15:45
  • Please try these links: youtube.com/watch?v=wCt9DBIWF54 ifixit.com/Answers/View/381560/ThinkPad+lenovo+not+charging and if neither helps, please find the serial number plate. On it will be the model number beginning with "20G". Please click edit and provide the complete model number. Please do not click Add Comment. My objective is to find the exact model number (as "ThinkPad 13 1st Gen" points to multiple models) then try to find an external dock with charging ability, but I must have the exact model number.
    – K7AAY
    Jul 9, 2019 at 21:50
  • I did write the model number, thanks.Well, today was surprising: I found my laptop with only 1% battery left, I plugged it in and, miracle, it worked perfectly - until being charged at 100%. Then I removed the AC and the battery went down to a few percent. I plugged it in a few minutes ago, and now I still have the exact same problem: the battery is blocked at 6% but doesn't charge (this is written "estimating..." with no time). I don't see any solution except going to (another) repair shop now.
    – Clem.
    Jul 11, 2019 at 20:12

0

You must log in to answer this question.

Browse other questions tagged .