3

Trying to update Midnight Commander to the latest version (4.8.23), I downloaded the corresponding tar.xz file from their website (http://ftp.midnight-commander.org/?C=N;O=D), extracted the files and issued ./configure, but afterwards I get the error:

configure: error: S-Lang library version 2.0 or newer not found

However, the output of sudo apt-get install libslang2 tells me I already have the newest version (2.3.1a-3ubuntu1) of that library.

What may be the problem?

2

I've got the same problem on Fedora. The solution I found was to install slang-devel package:

sudo dnf install slang-devel

Installing this package somehow fixes the configure error. The solution was found here (in Russian):

И вновь досадная ошибка:
configure: error: S-Lang library version 2.0 or newer not found
Исправляем установкой пакета:
# yum install  slang-devel

I believe there is a corresponding slang-devel package in Ubunu as well.

1
  • 1
    Thanks a lot. libslang2-dev was the package name in Ubuntu. I also had to install libglib2.0-dev, and then everything worked.
    – user596332
    Jul 25 '19 at 12:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy