0

I am trying to install docker on my Raspberry Pi and can't seem to get this to work.

I've tried few solutions suggested here (including installing python-setuptools) but none seem to work.

Any ideas how to fix this?

pi@raspberrypi:~ $ sudo apt-get -y install python-setuptools && sudo easy_install pip  && sudo pip install docker-compose~=1.23.0 

Reading package lists... Done 

Building dependency tree Reading state information... Done 

python-setuptools is already the newest version (40.8.0-1). 

0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. 

sudo: easy_install: command not found
New contributor
Han is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
1

Unless you need easy_install for something else, you might be better off installing pip from the system package manager:

apt install python-pip

or

apt install python3-pip

if you want to use Python 3

New contributor
nayrangnu is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

Han is a new contributor. Be nice, and check out our Code of Conduct.

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.