0

I upgraded to a new motherboard recently and found out Windows 7 does not support USB 3.0, so I went on a bit of a journey trying to install drivers for this.  Long story short, nothing worked and I ended up trying a last ditch effort of manually installing unsupported drivers by following this post on reddit:

https://www.reddit.com/r/Amd/comments/catb3t/i_fixed_windows_7_usb_support_for_matisse_ryzen/

However, as I expected, this did not work.  The problem now is that when I login to Windows, after a few seconds it bluescreens.  I am now trying to find a way to uninstall this driver either in the few seconds before my computer blue screens or using a repair disk.

So far I have tried launching in safe mode, quickly navigating to Device Manager and attempting to uninstall the drivers before it crashes, repairing my Windows install using the install disk.  I am not able to boot into safe mode at all.

I’m posting here before I finally give up and just install Windows 10 (which I would rather not do). I do not have any kind of system restore point.  I can still access the files and stuff from my Linux installation, so I’m not worried about losing data; I just would like to get my Windows 7 install working again.

Edit: I can and have changed the file back, but I’m assuming the driver needs to be reinstalled using this file.

  • can you undo the changes to the "amdxhc.inf" file ? And did you manage to uninstall the driver in safe mode ?? – Elmo Jul 14 at 5:21
  • Welcome to Super User.  It would appear that you have accidentally created two accounts.  This will interfere with commenting, editing your own posts, and accepting an answer.  You should use the contact form and select “I need to merge user profiles” to have your accounts merged.  In order to merge them, you will need to provide links to the two accounts.  For your information, they are superuser.com/users/1062357/jake and superuser.com/users/1062364/jake-ganz.  You’ll then be able to edit your question. – G-Man Says 'Reinstate Monica' Jul 14 at 6:44
  • Windows 7 supports USB 3.0. The Windows 7 SP1 ISO does not contain said driver within the installation environment. The problem, in this case, is you didn't have compatible drivers for the chipset. – Ramhound Jul 14 at 13:18
1

Try the following commands from a command prompt (assuming C: is where windows is installed).

If you can boot to a command prompt without crashing, do that, otherwise boot from Windows 7 installation media > Repair Your Computer, and find the command prompt option.

dism /image:C: /Get-Drivers - to see a list of drivers

dism /image:C: /Remove-Driver /driver:<drivernamehere>.inf> - to remove drivers (replace <drivernamehere> with the desired driver)

if you used the amdxhc.inf driver (from the link you provided), try:

dism /image:C: /Remove-Driver /driver:amdxhc.inf

If that doesn't work, you may need to use the <published name> (like oem#.inf) that is associated with the amdxhc.inf driver - this can be found using the first command above. I believe this behavior (requiring <published name> was implemented after Windows 7 but I don't have a copy to test on.

Here's some links about DISM driver servicing:

Driver Servicing Command-Line Options

Add and Remove Drivers Offline

You'll need to use /Image:C:, not /Image:C:\test\offline as the examples show, because you are servicing your local windows installation, not an image that you have mounted elsewhere, like the documentation assumes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.