0

In short, I can't open spyder and all the packages (as viewed in Environments) begin with 100. Trying to open spyder throws the following error:

Traceback (most recent call last): File "C:\Users\Owner\Anaconda3\Scripts\spyder-script.py", line 10, in sys.exit(main()) File "C:\Users\Owner\Anaconda3\lib\site-packages\spyder\app\start.py", line 186, in main from spyder.app import mainwindow File "C:\Users\Owner\Anaconda3\lib\site-packages\spyder\app\mainwindow.py", line 90, in from qtpy import QtWebEngineWidgets # analysis:ignore File "C:\Users\Owner\Anaconda3\lib\site-packages\qtpy\QtWebEngineWidgets.py", line 22, in from PyQt5.QtWebEngineWidgets import QWebEnginePage ValueError: PyCapsule_GetPointer called with incorrect name

I have been using Anaconda (more broadly python) for a couple months now. I was trying to install pyqt5 using the command

pip install pyqt5

it gave me an error saying something along the lines of "spyder is out of date" So I updated spyder using

conda update spyder

which seemed to work. Then I tried pip installing pyqt5 again and it worked with an error which I can't remember. The problems started after I restarted Anaconda and spyder still says it is not updated.

Thanks, Kelsey

0

conda install -c anaconda pyqt

1
  • While this may technically answer the question, this answer could be much improved by explaining why your solution works. – Worthwelle Nov 20 '19 at 15:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.