0

In an attempt to setup dual-boot on my Dell Precision 5530 I disabled Secure Boot in the BIOS, and enabled the Legacy ROM (something or other) option (really can't remember the exact wording). Now when I turn on the machine, it lights up, fans start going, but nothing else happens. The screen is blank, and it goes nowhere. There is no logo, no POST sequence. Nothing.

I've tried going into the BIOS again (F2) to no avail. I've tried pressing ESC to see if anything shows up on the screen that might be hidden. I've tried F12 as I know some other Dell models use that key. I've also inserted my USB with Ubuntu on it to try and boot, but still get nothing. Help!

1
  • 1
    For a dual-boot you never change the mode because you want to have all OSes installed in the same mode and in any UEFI machine that mode is UEFI. The first mistake then was changing to Legacy which automatically prevent the typically UEFI installed Windows from booting. Secure Boot is a feature only available in UEFI mode and it's not mandatory to disable it for Ubuntu but in certain circumstances it surely helps turning it off (and doing so is not problem for Windows either. Please open UEFI settings and undo that mistake (Legacy). It's the same key, same procedure.
    – user931000
    Jul 17, 2019 at 20:57

4 Answers 4

1

If anyone else runs into this problem I recommend trying a hard reset.

https://www.dell.com/support/kbdoc/en-us/000130881/dell-pc-does-not-turn-on-or-boot-into-windows

  1. Turn off the computer.
  2. Disconnect the ac adapter or power cord from the computer
  3. Disconnect all external devices
  4. Press and hold the power button for 15-20 seconds to drain residual power.
  5. Connect the ac adapter or power cord
  6. Attempt to power on the computer

This worked from me, I did get a repairing c: drive the first time it booted, then on the second boot it fully started.

1
  • Thanks - this worked for me on a seemingly bricked Precision 5530 laptop.
    – Paul R
    Apr 29 at 9:59
0

If NOTHING else works (aka you have a brick), reset the BIOS by removing the coin cell battery on the motherboard, waiting, then putting it back. This should at least get you back to having an accessible bios. It might even get you back to a boot state.

  1. Doing this step might void any warranty.
  2. Opening and disassembling a laptop is not usually fun. Be sure to keep the parts organized and take lots of pictures as you go. Otherwise.. it IS NOT difficult. After all.. you have the manual.

Here is your manual. You will find instructions on page 30.

0

In the end I let the battery die (since this model I can't easily take it out without opening the chassis), and when I turned it back on I was able to get into the BIOS. Thanks all.

0

If anyone else is having this same boot issue, here's what I recommend.

Senor CMasMas said to remove the CMOS battery, but in some cases, this won't work. This happened in the case of my Lenovo Thinkcentre M900z.
1. Look for three pins relatively close to the CMOS battery. These are called the CMOS Jumper pins.
2. Your instruction manual will have other instructions, but in most cases, move the jumper from pins 1 and 2 to pins 2 and 3. This is the Repair/Recovery/Reset position and will tell the system to reset the BIOS. Check your manual for your system's specific recovery pins.
3. Turn it on and wait for POST to beep a few times, then turn it back off. Put the CMOS Jumper back, and it should be back to normal.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.