1

A strange story, folks. Having upgraded Debian from Stretch to Buster, I can't run my favorite window manager. The hardware is a dual-monitor PC with Intel integrated controller (Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller). xrandr recognizes VGA-1 and HDMI-2 monitors.

  1. Running 'startx xterm' from command line seems to hang. The screen shows some first lines printed by Xorg during startup. However, Xorg is working. Via SSH, I can run applications (but can't see them on screen), I can make a screenshot, like this: https://imgur.com/74QFRLe. I just can't see anything. However, switching VTs causes Xorg to crash.
  2. I can run gnome-session and it works fine on both monitors.
  3. I can run startkde and it shows up, but only on one of the monitors (VGA-1), the other one remains black. It seems that an important step in startkde is running kstartupconfig5. Without it, kwin also remains invisible.

If I use gdm instead of running things from command line, I can run Gnome, old Gnome and Gnome with Xorg. Other window managers do not work, leaving only black screen.

5
  • 1
    What happens if you a) try to change the background using hsetroot or xsetroot? b) start a compositor such as compton --backend glx or compton --backend xrender?
    – user1686
    Jul 18, 2019 at 12:48
  • All commands work as expected. xsetroot -solid blue paints the screens blue while compton --backend xrender turns the background to gray: imgur.com/a/I2VuzHu. The effect, though, remains invisible. But compton --backend glx did work, to some degree. On the screenshot the result is identical to that of xrender backend, but the Xorg text output disappears and VGA-1 display gets gray background. The other one, though, becomes solid black.
    – minaev
    Jul 19, 2019 at 4:52
  • 1
    What Xorg modules are being used for the GPU For example, Intel/old ATI/new AMD can use xserver-xorg-video-{intel,radeon,amdgpu}, or they can use the built-in 'modesetting' module. (In other words, if you have the "intel" module installed, try removing it; and if you don't have it, try installing it.)
    – user1686
    Jul 19, 2019 at 4:57
  • 1
    (Most of the "driver" code is really in the kernel, and it's the same driver regardless of using Xorg with intel, Xorg with modesetting, or even Wayland. The most significant differences, however, come in how they handle 2D acceleration – e.g. the intel driver offers UXA and SNA while modesetting is OpenGL-based. The fact that both GNOME Shell and "compton --backend glx" work for you makes me think you'll have more luck with modesetting. Although, that said, I have completely no idea where the real problem is.)
    – user1686
    Jul 19, 2019 at 5:00
  • You nailed it. Thanks!
    – minaev
    Jul 19, 2019 at 6:18

1 Answer 1

0

I think I did it, using https://wiki.archlinux.org/index.php/Intel_graphics. First, I created xorg.conf and enabled "intel" driver:

Section "Device"
  Identifier  "Intel Graphics"
  Driver      "intel"
EndSection

And here it is! It gave me two identical pictures on two monitors. Then I added a bit more to make them one single desktop:

Section "Monitor"
    Identifier  "VGA1"
    Option      "Primary" "true"
EndSection
Section "Monitor"
    Identifier  "HDMI2"
    Option      "LeftOf" "VGA1"
EndSection

And here is my favorite StumpWM :)

2
  • Did you have to install the driver as a package first? Normally it should get autodetected as long as it's installed, only reverting to 'modesetting' if missing... or if you had a custom Xorg.conf. (I forgot to ask this, but did the previous broken config leave any messages in your ~/.local/share/xorg/Xorg.0.log? It would be good to know why it broke.)
    – user1686
    Jul 19, 2019 at 6:22
  • No, I didn't install the driver. It was installed automatically together with xserver-xorg and all other drivers. I didn't have xorg.conf, nor any other customizations in xorg.conf.d directory. As for the log, here are some suspicious lines : [ 17107.644] (EE) modeset(0): failed to set mode: Invalid argument [ 17107.692] (II) modeset(0): Allocate new frame buffer 3840x1920 stride [ 17107.710] (EE) modeset(0): failed to set mode: Invalid argument Full log here: pastebin.com/eZjzbMWg
    – minaev
    Jul 19, 2019 at 7:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.