Problem: BIOS supervisor password that is forgotten.

Manufacturer: Acer
Model: Aspire E5-571G
Architecture: 64 bit
OS: Win 10
Motherboard: Acer EA50_HB(U3E1)

BIOS.ver: Insyde Corp.V1.32, 15.09.2015(latest)
SKU: Aspire E5-571G_0867_V1.32
SMBIOS.ver: 2.8

Experience with BIOS: Close to zero, and I also don't happen to have handy hardware programmer tools for this purpose at hand.

What I have done so far:

  1. Entered a wrong password three times, getting a code and putting it into online generators
    (50648485 → 45720401)
  2. Downloaded Acer Empowering Technology+Acer eSettings Management for password drop (Deprecated software last developed for win XP that obviously didn’t work on win 10)
  3. Tried to boot USB with clnpnwd (boot menu on F12 or del is disabled in BIOS it seems), also tried to remove the HDD to force USB boot but ended up with “No boot device”
  4. Disassembled the whole device to see a soldered CMOS battery at the very bottom knowing that: a) I don’t have much experience soldering (though I do have a knowledgeable neighbor)
    b) a reset might not work in this particular case because of EEPROM (from what I have read).
  5. Flashed latest BIOS from Acer website modifying platform.ini [Force Flash] part "Password=0" to "Password=1" (Nothing changed)

Things to try from my head:

  1. Acer seems to refuse to assist customers with BIOS password issues(backdoor key) unless you send the laptop to them and pay a $100 fee (I live in a squat eating freegan stuff with zero dollars in my pocket).
  2. Swap HDD to another one with clnpnwd on it (no spare HDD atm)
  3. Flash some custom BIOS (pure blind black magic), but according to my limited research it doesn’t exist for this model and I don’t even know if it would help.
  4. BIOS recovery as stated on BIOS mods website in the “Insyde BIOS Recovery” but
    a) tools from “paragraph 3” mentioned there do not exist
    b) I have BDW.fd and HSW.fd in my BIOS folder from acer (extracted from temp folder) and it seems only 1 is needed
    c) I am not sure it is in any way related to the password issue
  5. Reserved for suggestions because so far I am out of ideas but I truly believe it is possible to accomplish without working as a coitus-slave to pay acer.

I would be incredibly grateful for any help provided.

P.S If there is documentation/book/manual/whatever to read and it contains something you don't want to explain [but is useful] in solving the problem feel free to link/post the name of the literature/etc. and I will do my best to acquire new knowledge to increase my competence.

  • 1
    Unfortunately for you the only option is (payed) tech support from the manufacturer. – GabrielaGarcia Jul 18 at 18:59
  • Thank you for your response even though it is sad haha, do you imply that there is no other way like invading EEPROM or anything like that left for me to do(at least that you know of)? Or was it meant to be more like "the easiest method" to follow I know it might be write-protected but there are so many BIOS enthusiasts out there that I had some hope left for the bush goarounds. – jeancroissand Jul 18 at 19:04
  • what do you need to change in BIOS that would require the password? hopefully you have also tried a variety of default passwords, and just leaving the password field blank and pressing enter – mael' Jul 18 at 19:06
  • I am, in fact, 75% sure it was me who for some uknown reason set that password months ago and as it is not my main laptop I didn't experience any problems but now I want a machine that will be able to withstand AOSP compilation for my nexus 5x and it is definitely not my Lenovo Thinkpad 230x with 120G SSD. Boot menu is disabled in BIOS, that is the main obstacle for now at least so I can't install Ubuntu with my windows to peform the operation. – jeancroissand Jul 18 at 19:08
  • Though I am aware of "Windows Subsystem for Linux (Beta)" way but it is not supported by my version of Windows and one of the possible solutions would be acquiring one that does but that will still leave me with locked bios for possible future needs if that works at all. – jeancroissand Jul 18 at 19:13

I found one more method that you have not tried in the article How to Reset an Acer BIOS Password.

I list it below (but without any guarantee):

  1. Disconnect the power cord

  2. For a desktop, remove the cabinet cover.
    For a laptop, turn it upside-down and remove the battery. Open the hard drive compartment by sliding the cover out and unscrew and pull out the hard drive.

  3. Several possibilities:

    • Locate a coin-shaped clock battery (also known as CMOS Lithium battery) and remove it. Keep it aside for at least an hour.
    • For a laptop, disconnect the tiny power lead that connects the clock battery to the motherboard. Keep it disconnected for at least an hour.
    • Otherwise, search for a BIOS reset jumper marked CLRP1 and move to Clear position. Leave it in this condition for at least an hour.
  4. After about an hour, replace the battery in the socket or move the jumper back to the Run position.

  5. Fit the cabinet cover and start your computer.

  • EEPROM might be the problem in case of physical reset but at the same time it may not be as even after wikipedia article and a few forum posts I am still questioned by how it functions exactly and whether it protects from "jumper and CMOS resets". Moreover I would like to reside to physical terms of solving last as the window for mistake is exponentially wider. But thank you. – jeancroissand Jul 21 at 16:40

New idea that came to my mind: 1. Disconnect every storage devices including HDD with windows from laptop 2. Make a bootable HDD with clnpwd and put it back into laptop as the only storage 3. Reset password with clnpwd

Question regarding how to make a bootable HDD from me(no answer yet): How to turn HDD into DOS bootable device to run a particular utility?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.