2

I have an Intel NUC connected directly to my router by a short Ethernet cable, running Debian 9. According to speedtest-cli, it's getting about 4mbps up and down, roughly symmetric. Meanwhile, most devices on the network (all connected via WiFi) are getting in the neighborhood of 150 down and 25 up.

My first thought was obviously that the cable might be defective. I swapped it out and nothing improved. I then hooked the old one up to my personal laptop and got a perfectly acceptable speed through it. I then installed nload and iftop to monitor bandwidth utilization on the NUC and those tools are reporting a handful of bytes/second inbound and ~10kbps outbound.

Any ideas on what the issue is? Could my connection be throttled by some settings I have at the OS or software layer? Or could it simply be that the Ethernet port on my NUC is defective?

EDIT: dmesg | grep eno1

[    2.577149] e1000e 0000:00:1f.6 eno1: renamed from eth0
[    3.637208] IPv6: ADDRCONF(NETDEV_UP): eno1: link is not ready
[    3.850216] IPv6: ADDRCONF(NETDEV_UP): eno1: link is not ready
[  428.371163] e1000e: eno1 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: Rx/Tx
[  428.371236] IPv6: ADDRCONF(NETDEV_CHANGE): eno1: link becomes ready

When I grep for the previous name of that network interface (dmesg | grep eth0) I get this:

[    2.575818] e1000e 0000:00:1f.6 eth0: (PCI Express:2.5GT/s:Width x1) 94:c6:91:a8:1c:89
[    2.575823] e1000e 0000:00:1f.6 eth0: Intel(R) PRO/1000 Network Connection
[    2.575937] e1000e 0000:00:1f.6 eth0: MAC: 12, PHY: 12, PBA No: FFFFFF-0FF
[    2.577149] e1000e 0000:00:1f.6 eno1: renamed from eth0

EDIT2: ethtool eno1 spits out the following:

Settings for eno1:
    Supported ports: [ TP ]
    Supported link modes:   10baseT/Half 10baseT/Full 
                            100baseT/Half 100baseT/Full 
                            1000baseT/Full 
    Supported pause frame use: No
    Supports auto-negotiation: Yes
    Advertised link modes:  10baseT/Half 10baseT/Full 
                            100baseT/Half 100baseT/Full 
                            1000baseT/Full 
    Advertised pause frame use: No
    Advertised auto-negotiation: Yes
    Speed: 1000Mb/s
    Duplex: Full
    Port: Twisted Pair
    PHYAD: 1
    Transceiver: internal
    Auto-negotiation: on
    MDI-X: on (auto)
    Supports Wake-on: pumbg
    Wake-on: g
    Current message level: 0x00000007 (7)
                   drv probe link
    Link detected: yes

EDIT3: output of lsmod

snd_hda_codec_hdmi     49152  1
snd_hda_codec_realtek    90112  1
snd_hda_codec_generic    69632  1 snd_hda_codec_realtek
nls_ascii              16384  1
nls_cp437              20480  1
vfat                   20480  1
fat                    69632  1 vfat
btusb                  45056  0
btrtl                  16384  1 btusb
btbcm                  16384  1 btusb
btintel                16384  1 btusb
joydev                 20480  0
bluetooth             552960  5 btrtl,btintel,btbcm,btusb
uas                    24576  0
usb_storage            73728  1 uas
intel_rapl             20480  0
x86_pkg_temp_thermal    16384  0
intel_powerclamp       16384  0
coretemp               16384  0
kvm_intel             200704  0
kvm                   598016  1 kvm_intel
evdev                  24576  8
snd_soc_skl            65536  0
irqbypass              16384  1 kvm
snd_soc_skl_ipc        45056  1 snd_soc_skl
snd_soc_sst_ipc        16384  1 snd_soc_skl_ipc
snd_soc_sst_dsp        32768  1 snd_soc_skl_ipc
snd_hda_ext_core       28672  1 snd_soc_skl
snd_soc_sst_match      16384  1 snd_soc_skl
crct10dif_pclmul       16384  0
snd_soc_core          212992  1 snd_soc_skl
crc32_pclmul           16384  0
snd_compress           20480  1 snd_soc_core
efi_pstore             16384  0
snd_hda_intel          36864  0
i915                 1257472  4
iwlwifi               151552  0
snd_hda_codec         135168  4 snd_hda_intel,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec_realtek
rtsx_pci_ms            20480  0
snd_hda_core           90112  7 snd_hda_intel,snd_hda_codec,snd_hda_ext_core,snd_soc_skl,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec_realtek
snd_hwdep              16384  1 snd_hda_codec
cfg80211              589824  1 iwlwifi
snd_pcm               110592  7 snd_hda_intel,snd_hda_codec,snd_hda_ext_core,snd_hda_core,snd_soc_skl,snd_hda_codec_hdmi,snd_soc_core
drm_kms_helper        155648  1 i915
ghash_clmulni_intel    16384  0
memstick               20480  1 rtsx_pci_ms
rfkill                 24576  3 bluetooth,cfg80211
efivars                20480  1 efi_pstore
pcspkr                 16384  0
snd_timer              32768  1 snd_pcm
drm                   360448  5 i915,drm_kms_helper
mei_me                 36864  0
iTCO_wdt               16384  0
snd                    86016  10 snd_compress,snd_hda_intel,snd_hwdep,snd_hda_codec,snd_timer,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec_realtek,snd_soc_core,snd_pcm
iTCO_vendor_support    16384  1 iTCO_wdt
sg                     32768  0
soundcore              16384  1 snd
i2c_algo_bit           16384  1 i915
intel_pch_thermal      16384  0
shpchp                 36864  0
mei                   102400  1 mei_me
wmi                    16384  0
video                  40960  1 i915
tpm_crb                16384  0
acpi_pad               24576  0
button                 16384  1 i915
efivarfs               16384  1
ip_tables              24576  0
x_tables               36864  1 ip_tables
autofs4                40960  2
hid_generic            16384  0
ext4                  589824  1
usbhid                 53248  0
crc16                  16384  2 bluetooth,ext4
hid                   122880  2 hid_generic,usbhid
jbd2                  106496  1 ext4
crc32c_generic         16384  0
fscrypto               28672  1 ext4
ecb                    16384  0
mbcache                16384  2 ext4
sd_mod                 49152  4
rtsx_pci_sdmmc         24576  0
mmc_core              147456  1 rtsx_pci_sdmmc
crc32c_intel           24576  2
aesni_intel           167936  1
aes_x86_64             20480  1 aesni_intel
glue_helper            16384  1 aesni_intel
lrw                    16384  1 aesni_intel
gf128mul               16384  1 lrw
ablk_helper            16384  1 aesni_intel
cryptd                 24576  3 ablk_helper,ghash_clmulni_intel,aesni_intel
rtsx_pci               57344  2 rtsx_pci_sdmmc,rtsx_pci_ms
mfd_core               16384  1 rtsx_pci
e1000e                249856  0
ptp                    20480  1 e1000e
pps_core               16384  1 ptp
ahci                   40960  3
libahci                32768  1 ahci
xhci_pci               16384  0
i2c_i801               24576  0
i2c_smbus              16384  1 i2c_i801
xhci_hcd              188416  1 xhci_pci
libata                249856  2 ahci,libahci
scsi_mod              225280  5 sd_mod,usb_storage,libata,uas,sg
usbcore               253952  6 usbhid,usb_storage,xhci_pci,btusb,uas,xhci_hcd
usb_common             16384  1 usbcore
thermal                20480  0
14
  • 1
    I used the USB-to-ethernet dongle to see if my ethernet port was the issue, and it worked, I got 100mbps over USB. Then I rebooted and suddenly both connections were being to limited to 4mbps again. That made it seem like a software issue, so I tried with a fresh OS install, and I'm still stuck at 4mbps. Totally at a loss here. Jul 20 '19 at 17:36
  • Also tried a cat6 cable instead of cat5e to see if that would make any difference, with no effect. Very reliably within ~1% of 4.00 mbps up and 3.50 mbps down Jul 21 '19 at 1:48
  • 150 Mbs up and 25 down? Are you sure you're measuring accurately? It's unusual, in my experience, for a consumer internet connection to have a higher upload speed than download speed.
    – Jim L.
    Jul 21 '19 at 1:55
  • There is a recent BIOS Update that you may try (verify it pertains to your model). See BIOS Update Instructions. In case of disaster see BIOS Recovery.
    – harrymc
    Jul 21 '19 at 5:55
  • @JimL. measuring accurately but typing tit backwards. I just fixed that Jul 21 '19 at 19:20
0

Your issue may be related to versions (kernel/firmware).

To help diagnosing your slow ethernet connection (your question), you may see what happens with your WiFi (and perhaps you remain comfortable with it).

As per official documentation, your NUC should have an

Integrated Wireless‡: Intel® Wireless-AC 8265 + Bluetooth 4.2

As per this, you'd rather use Ubuntu 16.10 (kernel version 4.8.0-xx) to get it working. This confirms that 4.6+ is needed for Intel 8265. I guess 16.06 (which you tried) may not provide the same functionally in this respect.

This and this and may help you have a working WiFi with your NUC.

This indicates that linux-firmware_1.169.2_all.deb runs with no issues.

Perhaps all this also fixes the auto shut-off you are seeing, and also the ethernet issue.

7
  • Thanks! Those references and drivers are for the wi-fi hardware, but I'm trying to use an ethernet connection. On 16.10, I wasn't able to install the software I need because the repositories are no longer supported. When I upgraded to 18.04 instead (the only reason I was using 16.x was that it so happened that Canonical had once released a NUC-targeted distribution of 16 a few years ago) I found that the download speeds were fixed (180 mbps) but there was no change at all in my upload speeds, which were still limited to 3.54 mbps. Any thoughts on why only one direction would be working? Jul 27 '19 at 17:11
  • Using the built-in wifi hardware I have notably worse speeds than I did under Debian 9 for either wifi or ethernet (2.5 mbps download speed and strangely higher 3 mpbs uploads) Jul 27 '19 at 17:18
  • @xanderflood - I know I posted stuff related to WiFi, and you are having trouble with ethernet. I even accounted for that in my answer. But you mentioned that you don't have WiFi at all, so I thought clarifying that, and suggesting alternative versions of firmware/kernel may help diagnosing your problem as well. Jul 28 '19 at 15:31
  • @xanderflood - So now you found your WiFi and have it working? (albeit at possibly low speed). Jul 28 '19 at 15:32
  • Unfortunately I didn't manage to get it sorted out before the bounty expired, but this was what ultimately led me there. I actually got it sorted out using 16.04 (16.10 is not LTS and the instructions for setting up archived APT sources for non LTS version that I was able to find on the internet did not work for me). Vanilla 16.04 works great, it was ironically only the NUC-specific 16.04 build that caused problems for me. I tried a dozen (literally) Ubuntu and Debian versions and each one had different combinations of hardware incompatibility until I went back to 16.04 and everything worked. Aug 14 '19 at 17:10
0

My first thought is that the NIC is operating in 10 Mbps half duplex mode. Or switching between different link speeds all the time due to some problem X we don't know yet. If that's true then that would hurt performance a lot.

Did you read the output the dmesg command gives to see if some network adapter related messages are printed while you are transferring data?

Usually the cards are on auto link negotiation (auto selects the correct speed, which is fine, don't change it!). Maybe you see some messages that are evidence that the adapter is confused and switching between link speeds all the time.

BTW: Which driver and driver version are you using? I don't know anything about the NUC, but I guess it has an Intel network adapter of some sort.

13
  • lspci spit out this line 3a:00.0 Network controller: Intel Corporation Device 24fd (rev 78), which I believe would be the driver. No new messages appears in dmesg while transmitting data :/ Jul 21 '19 at 20:29
  • I believe that device (8086:24fd) is actually the wireless module. And what does the ethtool output for your device? You may have to install the package for this tool first if you don't already have it. For instance my card is eno1 so I run ethtool eno1 and it gives me details about the connection. It also reports the link speed in this form: Speed: 1000Mb/s. Jul 21 '19 at 20:38
  • I added some dmesg and ethtool output to the original post! mine is also showing Speed: 1000Mb/s currently Jul 21 '19 at 20:41
  • And actually, I was not aware my NUC had a wireless module (no wireless interface appears in ifconfig). I'm going to see if I can configure it from the GUI and whether it suffers from the same throttling Jul 21 '19 at 20:42
  • Yeah, can confirm that there's no wireless device on this machine (although I believe you that there may be a wireless module installed anyways). I have an Edimax USB wi-fi adapter that I've been trying to get working but I haven't been able to compile the driver so far Jul 21 '19 at 21:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.