1

I recently installed Aptana Studio 3 (Eclipse 4.7) on my Mac PowerBook running Mojave (10.14.5). I've had errors at every turn (mostly Aptana complaining that it needed Java 1.6 and then complaining that it needed Java 1.8, after I'd installed Java 1.6). After reading a number of Mac/Aptana/Java articles, I believe I've found the correct Java version (Java 12.0.2), as now the Aptana splash screen and workspace path screens appear. However, I now get the following Java error (snippet) after selecting 'OK' on the workspace path dialogue.

I've tried making the edits suggested here (using /usr/bin/java as the path). But, I continue to get the same error.

I've looked at Mac how to articles, Eclipse forums and Stackoverflow entries, with no success. Any advice is greatly appreciated.

!SESSION 2019-07-19 08:50:36.186 -----------------------------------------------

eclipse.buildId=unknown java.version=12.0.2 java.vendor=Oracle Corporation BootLoader constants: OS=macosx, ARCH=x86_64, WS=cocoa, NL=en_US Framework arguments: -keyring /Users/xxxxx/.eclipse_keyring Command-line arguments: -os macosx -ws cocoa -arch x86_64 -keyring /Users/xxxxx/.eclipse_keyring

!ENTRY org.eclipse.osgi 4 0 2019-07-19 08:50:41.780 !MESSAGE Application error !STACK 1 org.eclipse.e4.core.di.InjectionException: java.lang.NoClassDefFoundError: javax/annotation/PostConstruct at org.eclipse.e4.core.internal.di.InjectorImpl.internalMake(InjectorImpl.java:410) at org.eclipse.e4.core.internal.di.InjectorImpl.make(InjectorImpl.java:318) at org.eclipse.e4.core.contexts.ContextInjectionFactory.make(ContextInjectionFactory.java:162) at org.eclipse.e4.ui.internal.workbench.swt.E4Application.createDefaultHeadlessContext(E4Application.java:491)

0

Please have a look at my answer here. For me Aptana Studio only runs with Java 8.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.