0

In Firefox (68.0.1 (64-bit)), I have changed some options for the zoom options:

In "View" tab, I have deselected "Zoom Text Only", so the entire page (including images) zooms in/out as I zoom.

I have also tweaked the about:config to the following:

browser.zoom.full set to false
browser.zoom.siteSpecific set to false

However, when I close and re-open FireFox, the "Zoom Text Only" gets selected, and the browser.zoom.full resets to TRUE.

Why is it not remembering my settings?

Edit: I know there are extensions to help with this, but I'd prefer to figure it out from the FireFox settings without Third-Party requirements.

Edit2: I checked the prefs.js in the Profiles folder, and it appears to have saved with false:

enter image description here

9
  • 1
    Try running Firefox as Administrator, save the settings and see if they now "stick". I've had similar issues with 7-Zip & Notepad++, setting file associations, that are made permanent only as Admin. Jul 19, 2019 at 17:10
  • @DrMoishePippik - Good idea, but doesn't seem to stick :(. I've also edited and checked that prefs.js is not in Read Only mode...
    – BruceWayne
    Jul 19, 2019 at 18:27
  • It's common for Firefox to change values in about:config on its own. You can attempt to override it using locked preferences, but it's not recommended.
    – Jason
    Jul 19, 2019 at 19:51
  • Is there more than one profile? Jul 19, 2019 at 19:53
  • 1
    That is suspicious; you own C:\Users\<batman>\AppData\Roaming\Mozilla\Firefox\Profiles\ . Check TaskManager to see if there is another instance of Firefox running though you've closed it. Also try LockHunter to see what is locking the alternate profile. Jul 19, 2019 at 20:57

1 Answer 1

0

I opened the Profiles folder, closed FireFox, deleted the prefs.js file, then went "up" a folder to just

C:\Users\B.Wayne\AppData\Roaming\Mozilla\Firefox\Profiles

Then right clicked my profile folder (6a45k87e.BWayne-1562154485368). This had the "Read-Only" tick box marked where some files are read-only. I cleared out the box (meaning, nothing is Read-Only), and Apply.

Then restarted FireFox, and so far it seems to be remembering my preferences.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.