0

I have installed MSSQL Server Express. But, the "database diagram" feature was not running. So, someone said to delete a folder named "SQL Server Management Studio" inside "Documents" in Windows to delete all the settings

I followed the same. But, it looks like 'authentication' is also part of setting

In SSMS, I can see the local server, but windows authentication & 'sa' user both are not working

How to set any authentication?

1 Answer 1

0

If you mean the option is not enabled when you right click the server/properties/security, then you could try altering this property directly from windows registry:

Step 1: Open the registry editor.

Step 2: Navigate to: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\MSSQL.10.SQLEXPRESS\MSSQLServer

Step 3: Change the value of LoginMode from 1 to 2.

Or you could just run

EXEC xp_instance_regwrite N'HKEY_LOCAL_MACHINE',
N'Software\Microsoft\MSSQLServer\MSSQLServer', N'LoginMode', REG_DWORD, 2

Font: https://www.isunshare.com/sql-server/four-ways-to-enable-mixed-mode-authentication.html

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .