3

I'm running Archlinux 5.2.0-arch2-1-ARCH and Android Studio 3.4.2

When I open an Android Simulator Device with (AVD Manager) an I'm reproducing any kind of sound (music on Spotify, or YouTube in a web browser) from any source, the sound gets distorted and kind of echoing.

I've noticed this does not happen when the simulated device is running with API 22 (Lollipop), but other versions (23 --> 29) present the same problem.

Any idea what could be the problem and how to solve it?

3

This is how I fixed it:

In /etc/pulse/default.pa change load-module module-udev-detect to load-module module-udev-detect tsched=0 (add "tsched=0") restart pulseaudio:

pulseaudio -k

Worked instantly ( no, your RAM is not "faulty")

source link

1

Is the sound card Realtek?

First of all try to give a minimum of 2 processor cores to the virtual device (emulator). Try to switch the RAM sticks in another slot. Give your emulator a minimum of 1GB RAM.

Note this problem happens to Android emulators on Windows 10 with Android Emulator set to 1 processor core, less than 1GB of RAM and having the Realtek RTS5170 sound card.

The issue could also be a faulty RAM stick, storage device, processor, sound card, motherboard, GPU and other similar items.

What is recommended try another host OS to see if the problem persist, such as Windows 10 or Ubuntu.

1
  • You basically listed everything without making any real point. Should we test in good weather and bad weather too? I switched MB/CPU/RAM everything adn just used the old software No problem, only Android emulator messes with the audio. This looks like simple plain old bug Jul 16 '21 at 4:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.