0

I am trying to run the OS found on the Pi-Top in VirtualBox (the OS can be downloaded here https://www.pi-top.com/products/os). However, said OS is available only in a .zip format, which then unpacks into a .img, which cannot be opened in VirtualBox.

I have tried using the steps outlined here (How to create a virtual machine from a .img disk image?) but to no avail; it always fails to find a bootable medium.

I have tried using IMGtoISO, but that also fails. I recently tried mounting the OS in windows 10, but that gave me the error "disk image file is corrupted." The thing is, I know the img does actually work; I have used it to flash SD cards with the OS numerous times, and it always boots on the pi-tops themselves whenever I then power them on. The OS runs with (relatively) few problems on the pi-tops, but I cannot get it to run in a VM.

I'm sure I'm doing something wrong or misunderstanding the file types involved (I am relatively new to using VMs, I will admit), but I can't figure out what to do.

All help would be appreciated.

  • pi-top runs on the Raspberry Pi board, which is a completely different architecture (ARM) than your Windows (Intel x86_64) computer running VirtualBox. In order to run an OS designed for a different CPU architecture, you'd need to use an emulator like QEMU that can emulate the Pi's CPU. Sourceforge offers a tool: sourceforge.net/projects/rpiqemuwindows – essjae Jul 22 at 17:55
  • Instructions for QEMU are here: pcsteps.com/1199-raspberry-pi-emulation-for-windows-qemu – essjae Jul 22 at 17:55
  • @essjae I was able to get regular pi OS to work, but every time I try to run pi-top OS I get this error ibb.co/WK0BXVy – I-Dislike-Javascript Jul 23 at 23:29
  • I'm not familiar enough with QEMU or pi-Top to give you much more help. – essjae Jul 24 at 17:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.