1

I've recently built a budget PC for my cousin and the parts are as follows:

  • CPU: Ryzen 5 1600
  • MB: Asus Prime B350-Plus
  • CPU cooler: Cooler Master 212 Evo
  • RAM: Corsair Vengeance 2666 MHz (2× 4 GB)
  • GPU: Asus 1060 6 GB OC edition
  • PSU: EVGA 500

I assembled the PC and turned it on for the first time and I have no display output or mouse power. What's strange is that the RGB lights up on the keyboard; the mouse and keyboard definitely work as they work in my own PC.

Things I have tried:

  • double and tripled checked all cables are seated correctly.
  • doubled and tripled checked the CPU is seated correctly.
  • waited 10-15 minutes for the first post as I've heard it can take a while on this mb with Ryzen.
  • booted with one stick of RAM in b2 (recommended in mb manual)

  • unplugged HDD and tried to boot

  • removed the Mb from the case and tried a bench set up test.

  • tried the GPU in both slots

  • I have a motherboard speaker and it doesn't beep at all

Does anyone have any ideas as to what the problem could be?

6
  • 1
    Looks like you have an incompatible CPU. "This motherboard comes with an AMD AM4 socket designed for AMD Ryzen™ / 7th Generation A-series / Athlon™ processors."
    – DavidPostill
    Jul 21, 2019 at 17:49
  • My CPU is an AMD Ryzen 5 1600, AM4 socket.
    – ImJhardy
    Jul 21, 2019 at 19:41
  • 1
    I know. But 5 is not equal to 7. Your MB is for Ryzen 7 CPUs
    – DavidPostill
    Jul 21, 2019 at 19:44
  • 1
    no it means 7th gen A-series, it can support ryzen 3/5 and 7. I mean forgive me if i'm wrong, but my friend has the exact same setup, b350 plus and ryzen 5
    – ImJhardy
    Jul 21, 2019 at 19:50
  • Your motherboard has an integrated graphics chip, so pull your GPU card as well when testing; when troubleshooting you want to reduce to fewest possible components, as any of them might be what is causing the problem. For first boot you can also yank mouse and keyboard until you can actually get video on boot. Also, are you getting any beep codes when booting? Normal boot is one beep, more than that is a coded error saying what is wrong. Jul 22, 2019 at 5:40

1 Answer 1

0

Turns out it was a dead motherboard. Requested a replacement and booted the first time.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.