0

Background:

I have an installation of Windows 10 on my C: drive, that up until Friday was working perfectly. Then, suddenly I get blue screens (Registry error) whenever trying to boot. I have tried many things to fix it, but the short of it is no program is able to recognize the disk as containing a Windows installation, so most recovery tools dont work.

Goal:

I loaded another SSD into my computer, with a working copy of Windows 10. I would like to transfer my files from the C: drive installation to a backup disk.

Problem:

The files are write protected and I don't have the ability to view the folders. When I try to enter a folder like C:\Users\<username> I get an error: "You don't currently have permission to access this folder". I tried using takeown and icacls to gain permission, but they did not work because the media is write protected. When I use diskparts to check the disk attributes here's what I get:

DISKPART> attributes disk
Current Read-only State : Yes
Read-only  : No
Boot Disk  : No
Pagefile Disk  : No
Hibernation File Disk  : No
Crashdump Disk  : No
Clustered Disk  : No

The Current Read-only State : Yes concerns me. From what I've read this normally has to do with a physical switch which my SSD definitely does not have.

Question:

How can I modify the permissions of the files on the C: drive, given that I have access to the admin Microsoft account and that I am personally the owner of the files?

  • You don't need write permission to read. – ctrl-alt-delor Jul 21 at 23:32
  • What commands did you try? What errors did you get? Your assumption this failed "because the media is write protected" is unfounded. – I say Reinstate Monica Jul 22 at 0:34
  • @ctrl-alt-delor There are many files that I am unable to read, and in order to add read permissions to the files, it seems I need write permissions – Jordan Epstein Jul 23 at 23:28
  • @TwistyImpersonator I've tried a lot of commands, I will edit the post to include more of what I've tried. The reason I think it's write protected is because when I use diskpart to list the attributes I get "Current Read-only state: True". Even though I am able to set "readonly" attribute to False. – Jordan Epstein Jul 23 at 23:30
  • 1
    That's good information to put into your question! – I say Reinstate Monica Jul 24 at 0:21