My problem is that modem (Modem / router #1 presented below) restarts itself, when I make git push with a lot of files (I'm not sure how big the push must be to break the connection, but smaller pushes with only a couple of files are working correctly). The same thing happens, when I'm connected with server via OpenVPN and I'm trying to upload a file through Samba.

Here's my home network setup (I have a home server exposed through ddns.net website):

Network setup

  1. PC is my home computer from which I'm sending requests. Its IP is random.
  2. PC is connected to Modem / router #1 via WiFi or LAN.
  3. Modem / router #1 also handles incoming requests - its public IP is used by ddns.net website. Its local IP is
  4. Router #2 is connected to Modem / router #1. Its IP on Modem / router #1 is
  5. Router #2 has its own local network, in which its IP is
  6. Server is connected to Router #2 via LAN. Its IP is
  7. ddns.net website requests go to Modem / router #1 and specific ports are forwarded to Router #2, which further forwards the request to Server, which finally handles the requests and sends a response the same way.
  8. Modem / router #1 model isn't easy to find, as it's just called "UPC Connect Box" (I'm from Poland and UPC is one of our ISPs), but I was able to find that it's software version is CH7465LG-NCIP-, which is used by Compal Broadband Networks CH7465LG-LC.
  9. Router #2 is TP-Link TL-WR841N.
  10. Server uses Lubuntu. lsb_release -a command returns:

No LSB modules are available.

Distributor ID: Ubuntu

Description: Ubuntu 18.04.2 LTS

Release: 18.04

Codename: bionic

  1. It's worth noting that such problems didn't happen in the past. I was able to upload files of any size on the exact same setup. I have no idea what could've changed.

Some things I've already tried / checked:

  1. PC connected to a mobile hotspot, instead of Modem / router #1 - in this case, everything works fine.
  2. PC connected to a Modem / router #1 via LAN instead of WiFi - the problem occurs in both cases.
  3. This solution from SO - doesn't change anything.
  4. I am able to see a log of Modem / router #1, which is unfortunately somewhat vague. When the restart happens, it simply states that "Cable Modem Reboot - due to power reset".
  5. Nothing wrong was found in server logs (at least in syslog and Samba logs).

I'm not expecting a ready solution for this problem, but I would really appreciate any advices on where can I start additional troubleshooting? What can I check to find out the cause of this behaviour?

-- Edit #1 --

I checked another possibility. When I'm connected directly to Router #2 via WiFi, it doesn't work as well. I must be completely outside my home network to make an upload. When I'm connected to Router #2, then it's still Modem / router #1 that resets itself.

-- Edit #2 --

Actually, after further analysis, check from Edit #1 doesn't really make sense, because it only adds another "node" to the request journey. I prepared a diagram of all three cases (PC connected to Modem / router #1 (UPC modem), Router #2 (TP-Link) and mobile hotspot). It may not be completely correct, it's really simplified, just to see how much work does the modem have.

Request diagram

-- Edit #3 --

Thanks to the diagram from Edit #2 I came to a conclusion, that I can try to reduce the work required by modem when I'm in the same network simply by accessing server by its local IP, instead of going through ddns domain. So when I pushed files to (which is an IP of TP-Link router on UPC - see the first diagram), it was forwarded directly to the server, thus decreasing a load on UPC modem and everything worked flawlessly. Why more operations on the modem are causing it to reboot is still a mistery to me, especially knowing that it worked a couple of months ago, but at least I have a workaround for now. The main problem still remains though and I'm afraid it may actually be a firmware issue. Any new ideas are still welcome.

-- Edit #4 --

After switching a power adapter for a completely new one, router still resets when doing a big git push. This happens with and without a fan cooling it. I'll contact ISP.

  • 2
    Why in all that is holy are you using Router#2 as a router, if you aren't using professional gear? Just disable the second router's DHCP and plug the primary router into the switch side, PLEASE. Put all your machines on the same segment.
    – Aron
    Jul 22 '19 at 3:44
  • @Aron First router has to be in a specific room, in which I don't want to have the server. I have a long LAN cable moved from first room to the second room. In the second room, server is not the only machine which requires a cable connection. I've already had an unused TP-Link router, so I've decided to use it as a switch. I'm not entirely sure, what do you mean by: "plug the primary router into the switch side"? Jul 22 '19 at 9:04
  • 2
    You said so yourself, you want to use it as a switch. A modern cheap consumer router is actually 4 devices, NATing router, DHCP server, WiFi AP and Ethernet Switch. The NATing router connects the WAN network to the LAN network-switch via a Routing Table & NAT. The DHCP server assigns IP addresses. Chances are you only need the WiFi AP and Ethernet Switch. Connect the Router #1 to Router #2 via the LAN ports.
    – Aron
    Jul 22 '19 at 9:36
  • 1
    Remember to turn off the DHCP before you do this, some router even have a bridge mode
    – Aron
    Jul 22 '19 at 13:21
  • 3
    Re Why more operations on the modem are causing it to reboot - most likely router power adapter is slowly failing (caps going bad or smtg similar). If possible, then replace it (same voltage and same connector required, bigger current output is recommended).
    – Arvo
    Jul 22 '19 at 13:28

It's faulty firmware, this did not happen with CH7465LG-NCIP- This issue is causing router restart when hairpin or loopback is being performed. With this error, you cannot use public IP or domain name inside your local network, because that is what causes reboot. It is couple of month now and still not fixed. You can ask your ISP to remotely downgrade to CH7465LG-NCIP- but the router updates itself anyway and ISP cannot stop it from doing so, so we are all screwed.

  • Thanks for the info! I'll definitely check it with ISP. Aug 21 '19 at 8:31
  • 1
    I also have UPC and they have already addressed this issue and are working on a fix. There is probably nothing more you can do right now. As I sad before, downgrading FW is temporary workaround, as router auto updates itself again after a day or two.
    – dwbmb
    Aug 23 '19 at 6:57
  • Well, we can only hope that when they find an issue in one country, they fix it everywhere :) I've asked our Polish service about this problem, now I'm waiting for a response. Aug 23 '19 at 13:59
  • I've just got my modem downgraded to the previous firmware version by ISP - it solved the problem completely. Thank you very much for your suggestions. Now we can only hope they'll fix it soon. I'm choosing this answer to be accepted, because it described an exact cause of my problem, but superuser.com/a/1462431/424167 is worth checking as well. By the way, I've got another info from UPC - modem should not be automatically updated after a downgrade. We'll see if it's true. Aug 26 '19 at 13:25
  • Minor update CH7465LG-NCIP- released, issue still not fixed.
    – dwbmb
    Sep 24 '19 at 17:05

You’ve made a well written, descriptive post. But, it’s written from the perspective that there must be something external to the modem causing the problem.

You wrote

I am able to see a log of Modem / router #1, which is unfortunately somewhat vague. When the restart happens, it simply states that "Cable Modem Reboot - due to power reset".

Nothing should ever cause a device to physically reset.

There are only three possible problems here:

  1. It’s hot and your modem is overheating. Increase air flow around the unit and test again. Put a fan directly on the unit.
  2. The modem or power adapter is bad. Get it replaced. It could be a firmware bug and you could ask the ISP to confirm that it is running the latest firmware, but I feel this is unlikely.
  3. Something is interrupting the power to the unit. Try a completely different outlet.

In my opinion, #1 is the most likely culprit and it may have already done irreversible damage requiring the modem to be replaced.

This is ISP equipment. You should be talking to them about why the modem is rebooting and then get it replaced if necessary.

  • 1
    But wouldn't it restart more often if overheating was the cause? It restarts itself only when I'm doing a very specific operation, which is uploading something to the server and the file has to be big enough to cause any problems. Opening websites hosted on the server works ok, as well as downloading huge files on full speed from other hosts. I'll try to get some info from ISP only when nothing else helps, I don't expect much help from them. Also, I'd say that bug in the firmware seems more likely - I didn't make any updates, but I can't be sure that modem doesn't do it in the background. Jul 21 '19 at 20:35
  • 6
    There is another possibility. All of the scenarios the OP posts about are large long lived TCP connections. There could be an overflow occurring in the router's firmware. I would be interesting to see if something similar happens with a) UDP connections and b) large numbers of small TCP connections. You load test both these scenarios with qBittorrent for instance.
    – Aron
    Jul 22 '19 at 3:38
  • 2
    @BartłomiejZieliński It's possible that it gets hotter when it's doing more work because more data is going through it.
    – user253751
    Jul 22 '19 at 3:58
  • 5
    @user20574 Why not? If the kernel dies due to an unrecoverable fault, which it was unable to log (because routers have lots of reliable persistent storage), AND some kind of firmware/watchdog power cycles the main SOC to recover, from the perspective of the micro distro, it did get "reset due to power reset".
    – Aron
    Jul 22 '19 at 6:39
  • 2
    If it's a firmware bug, the ISP will probably replace the modem with another one that has the same problem. Jul 22 '19 at 19:55

I had the same problem: I was trying to reach out to my NAS via HTTPS and a dynamic DNS. When copying large files, the router restarted with a "power reset" message. Changing the addressing mode to local IP solved the problem.


My suggestion is that this is a router problem. I have the same error with the UPC Connect Box CH7465LG-LC router. I would like to run a local server on one of two computers in my local network. The server has to be connected through public IP, so whenever I try connecting from the other computer I get the same error "Cable Modem Reboot - due to power reset". No overheating and definitely no power adapter failure. I hope UPC has solved this issue, still waiting for their support.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.