0

Host specifications: Cleaned Windows 10 (I have a feeling it's one of the many services I disabled in Windows, a list of required services for VirtualBox may help) Virtual Box: 6.0.10 r132072 (Qt5.6.20) VirtualBox Extension Pack 6.0.10 r132072

CPU: Ryzen 7 2700X - 4.3GHz 8C/16T
RAM: G.SKILL Ripjaws V Series (2x16GB@3200MHz)
Mother board: MSI X470 Gaming Pro Carbon
Video Card: MSI 8G 1080 Armor OC
Power Supply: EVGA 650W - EQ (80+ Gold)
1st Hard drive: Samsung Evo 970 - 1TB NVMe M.2 (OS Drive)
2nd Hard drive: Western Digital Red - 2TB 7200RPM
3rd Hard drive: Western Digital Blue - 1TB 7200RPM
Internet Adapter: Onboard Ethernet
Case: NZXT Source 530 (Do not recommend this case)
Cooler: Corsair H60 - 2x EVGA FX 120mm in a push-pull config

Guest Allocations: Ubuntu 18.04.2 Server (Also tried, Windows 7, Windows 10, Ubuntu 16.04.6)

8 Cores, 8GB RAM, 32 GB Fixed VDI storage on 1st hard drive, bridged network with Intel I211 Pro 1000T.

Other specs:
PIIX3 Chipset, I/O APIC, 128MB Video Memory, VMSVGA Controller, no acceleration, installation IDE PIIX4 no host I/O cache, virtual boot media AHCI SSD no host I/O cache, no audio.

This issue just recently popped up for me and I can't find anyone else with this issue. After shutting down my host PC, and forgetting to shutdown the guest machine correctly it tried to save the machine state. I canceled the host shutdown to cancel the machine state save. The next day I launch the guest and everything works fine until I put it under load. It crashes my host PC with either a BSOD or just force restart. I completely reinstalled virtual box, wiping every trace before reinstalling. I go to install the server and crashes immediately after starting the guest machine. I am using brand new everything, nothing from when the machine save state happened is being used.

When I get the BSOD, the stop code is "SYSTEM_SERVICE_EXCEPTION". I know this is the VM causing the crash, not the computer unable to handle a load. I have placed it under many stress tests and it runs fine.

Here are other things I tested;

  1. Switched to version 6.0.8 r130520 (Qt5.6.2) and got further than on the latest. I am able to get to the install Ubuntu screen, it makes it most of the way through until the end where it forcefully shuts off the host computer. No BSOD.

  2. Switched to version 6.0.6 r130049 (Qt5.6.2) and reduced the cores for the guest to 4, half my physical cores. This helped, but not quite fixed. It actually managed to boot to Ubuntu but crashed shortly after. Giving the BSOD "SYSTEM_SERVICE_EXCEPTION".

  3. Reinstalled Windows, no luck. I have no idea what the problem is. I tried enabling/disabling the acceleration settings, made sure AMD-V is enabled. I could really use some input.

  4. 7/24/19 - Reinstalled the program again (6.0.10 r132072) this time without the extension pack. Allocated 2GB of RAM and 1 CPU core to the guest to minimize possible issues. Left everything default aside from Audio (disabled) and networking (Bridged). Host system still crashed, though after significantly longer than any other previous attempts. I was actually able to run my stuff on it for a short while.

Any help is appreciated.

Edit 1: BSOD 1

BSOD 2

  • Use BlueScreenView and post screenshots of what it shows for the crash (like the 2 example views in the article). – harrymc Jul 22 at 16:48
  • @harrymc Edited original post. – diamondpumpkin Jul 22 at 22:32
  • Did you also do MemTest86 (see link)? Did you try to re-create the VM using only the hard disk? – harrymc Jul 23 at 4:53
  • @harrymc I ran memtest86, no errors. As far as I know, VMs can't use storage as memory. – diamondpumpkin Jul 23 at 9:41
  • I meant new VM with attached old virtual disk. – harrymc Jul 23 at 9:51
0

After hours of troubleshooting, I have finally resolved the issue. I use Avast Antivirus as my background protection, it usually doesn't cause any trouble but in this case there seems to be a conflict. Something Avast does when Oracle VirtualBox is running collides and crashes the system. I assume this is mainly on Avast's end so I will post on their forums.

Edit: Posted on Avast's website, apparently it uses some virtualization which the vm doesn't like. Here's the post: https://forum.avast.com/index.php?topic=228493.0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.