0

I wrongly configured my openwrt and lost access to my router. Using wireshark I discovered an IPv6 IP packet and can now ssh into it using only IPv6 IP address. But not from any browser.

Problem 1: I can though use lynx [fe80::eade:27ff:feed:8634%en6] and see LEDE login but I cannot do the same in any browser in Mac.

Problem 2: I don't know how to configure the network of my openwrt so that I can login into LEDE from a browser.

My router is not listing to 192.168.3.5. I had configured it as a bridge between my phone wireless to ethernet. Now its all gone wrong.

Dump of /etc/config/network:

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fd11:c5ac:cf22::/48'

config interface 'lan'
    option _orig_ifname 'eth0 radio0.network1'
    option _orig_bridge 'true'
    option proto 'static'
    option ifname 'eth0'
    option ipaddr '192.168.3.5'
    option netmask '255.255.255.0'

config interface 'ethernet'
    option _orig_ifname 'eth0'
    option _orig_bridge 'false'
    option proto 'dhcp'
    option type 'bridge'

config interface 'XYZZenfone'
    option proto 'dhcp'
    option _orig_ifname 'wlan0'
    option _orig_bridge 'true'
    option ifname 'eth0'
    option hostname 'LEDEStatic'

config interface 'XYZZenfone2'
    option proto 'dhcp'
    option type 'bridge'

config interface 'repeater_bridge'
    option proto 'relay'
    list network 'XYZZenfone2'
    list network 'lan'

Please suggest fixes in this network config so it takes a static IPv4 address listening to port 80 so that I can use it on a browser.

migrated from serverfault.com Jul 22 at 16:27

This question came from our site for system and network administrators.

0

Graphical web browsers don't allow accessing a site via a link-local IPv6 address literal in the URL.

You can work around this by giving the address a name and placing it in your computer's hosts file, which is at /private/etc/hosts on macOS. You will need to use sudo to edit it. An example configuration:

fe80::eade:27ff:feed:8634%en6 myrouter

Now you can go to http://myrouter/ in Safari (or any other browser) and access the router.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.