1

I recently changed the language on Windows 10 (version 1903).

The previous language was French and I wanted to change it to English. Nevertheless, I had to keep the AZERTY keyboard arrangement and the date format in French.

I proceeded in this way:

  • Settings > Time & Language
    • Language
      • Add a preferred language
        • English (United States) > Checked all boxes [Logout]
      • English (United States) > Options
        • Add a keyboard > French (AZERTY)
    • Region
      • Region format > French (France)
  • Administrative language settings
    • Copy settings > Checked all boxes [Restart]
    • Change system locale > English (United States) [Restart]

Attempted resolution made:

  • Delete the French language pack (and change all other Time & Language settings to English)
  • Rebuild the search index
  • Change the language code during Windows installation in the registry (HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Nls\Language > InstallLanguage (Language IDs))
  • Use Set-Culture (Documentation)

Nevertheless, when I do searches (from the task bar search bar and from the parameter search bar), the results obtained are in French.

Is there a solution to solve this problem?

Thank you.

2
  • 1
    Please provide some specifics. What language packs do you have installed? What keyboard layouts do you have? What is your display language configured too? Have you tried removing the other unwanted languages? Please edit your question, do not submit a comment, and provide this necessary vital information.
    – Ramhound
    Jul 23, 2019 at 1:00
  • @Ramhound thanks for the feedback, I updated the post.
    – MrSquaare
    Jul 23, 2019 at 8:58

3 Answers 3

0

The solution is far easier than that. The reason for this "bug" is because Windows indexes the settings options only in a certain scenario, the easiest way to do this I found on this link.

Before I had tried rebuilding index, renaming folders, nothing worked. Here are the steps:

  1. Open Control Panel (“Windows Settings”)
  2. Open “Time & Language”
  3. Click “Language” (on the left)
  4. Click “Administrative Language Settings” (on the right)
  5. A popup opened up, called “Region”. In the Tab “Administrative” and te field “Welcome screen and new user accounts”, click “Copy Settings”.
  6. Tick the boxes “Welcome screen and system accounts” and “new user accounts”.
  7. Click OK and reboot.
  8. Now, go to language settings, set back the “old” language (Germany in my case) as display language, sign out of windows, sign in again.
  9. Now Set English as display language, sign out of windows and sign in again.
1
  • Strange, but it works.
    – Vanav
    Jun 15, 2021 at 17:56
3

The following worked for me:

Try logging on with a another/new Windows account. If Settings search results are returned in the correct language using this account, then you will want to copy the following file from the working account to the problematic account:

%localappdata%\Packages\Microsoft.Windows.Cortana_cw5n1h2txyewy\LocalState\DeviceSearchCache\SettingsCache.txt

No restart needed, just start the Settings app again and searching should now return results in the correct language

2
  • I had to restart still (maybe that's because my Settings app was already launched, so it never really existed to begin with), but that is the only solution that, finally, worked for me. Thanks!
    – Jeto
    Jan 5, 2021 at 11:43
  • Thanks for this solution. Was the only one working for me (changing two German notebooks to English). Although the file was in a slightly different location: %localappdata%\Packages\Microsoft.Windows.Search_cw5n1h2txyewy\LocalState\DeviceSearchCache\SettingsCache.txt
    – stefitz
    Jun 23, 2021 at 19:05
0

I managed to solve the problem by recreating a new user. I suppose that to solve the problem without creating a new account, you have to reinstall and re-register the system applications (See here)

I hope that this answer will help some of them.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.