1

That might sound a bit stupid but I can't get my head around on where netflix.exe is actually located. I can see in my process manager that such a process actually exists when I open the app in Windows 10. The problem comes when I actually try to locate it.

I did some research, in previous versions was located in the C:\Program files\WindowsApp folder also tried in C:\Users\username\AppData\Roamming\Windows\Start Menu but no luck.

See reddit thread for further information.

I don't understand how I can see an exe in my process manager if such a file does not exist.

  • 1
    You can't find it because it is an app and Microsoft tries to shield users from accessing the files associated with apps. – LPChip Jul 23 '19 at 21:03
  • 3
    What @LPChip is attempting to indicate is that the Netflix application is a Universal Windows Program (UWP) application. UWP application executables are stored in a directory that by default no user has permissions to view (i.e. WindowsApp). Netflix does not have desktop Win32 application. Why are you trying to locate the application? If you no longer want the Netflix UWP application you should simply uninstall it. – Ramhound Jul 23 '19 at 21:26
  • @Ramhound I'm aware windowsapp folder access is not allowed by default to users. In fact I had to allow it to myself to have a look. As I said in the question netflix.exe is not there. The reason I'm trying to locate it is to put an exception rule to a vpn so Netflix does not use. I need to locate that exe. – user3770060 Jul 23 '19 at 21:43
  • UWP applications do not have .exe files. Only Win32 executables use that file extension – Ramhound Jul 23 '19 at 22:07
  • @Ramhound that's not true actually. UWP apps can have exe files, but they can also have multiple folders. For example, For Microsoft's YourPhone app, I have multiple folders, and one has the exe file, where another one has not. The fact that OP sees the process with .exe extension in the taskbar suggests Netflix has the exe stored somewhere in the UWP folder. – LPChip Jul 24 '19 at 7:55
3

PowerShell is a very powerful tool and can do pretty much anything with any Microsoft product, including UWP Apps.

To find where an appx is installed you can use the command Get-AppxPackage -Name PackageName.

The package names are usually very hard to guess, for example the current name of the Netflix app is "4DF9E0F8.Netflix". Some app names have 0 relation to the name shown in the start menu.

To make it a bit easier, you can use the Where-Object instead of the -Name parameter.

Get-AppxPackage | Where-Object {$_.Name -like "*flix*"}

This will look for any appx packages which name matches *flix*.

The result on my computer is this:

Name              : 4DF9E0F8.Netflix
Publisher         : CN=52120C15-ACFA-47FC-A7E3-4974DBA79445
Architecture      : X64
ResourceId        :
Version           : 6.93.478.0
PackageFullName   : 4DF9E0F8.Netflix_6.93.478.0_x64__mcm4njqhnhss8
InstallLocation   : C:\Program Files\WindowsApps\4DF9E0F8.Netflix_6.93.478.0_x64__mcm4njqhnhss8
IsFramework       : False
PackageFamilyName : 4DF9E0F8.Netflix_mcm4njqhnhss8
PublisherId       : mcm4njqhnhss8
IsResourcePackage : False
IsBundle          : False
IsDevelopmentMode : False
NonRemovable      : False
IsPartiallyStaged : False
SignatureKind     : Store
Status            : Ok

In the C:\Program Files\WindowsApps\4DF9E0F8.Netflix_6.93.478.0_x64__mcm4njqhnhss8 folder I can see that it's a WinJS app written in HTML, CSS and JavaScript.

There's no Netflix.exe in that folder?

There's not. I don't think you've ever seen a Netflix.exe (unless it's a virus). Here's a screenshot from my Task Manager while having Netflix up and running.

enter image description here

| improve this answer | |
0

I would tried adding WWAHost.exe (and maybe mfpmp.exe) to your VPN exception list. Those are the 2 .exe programs that are running when netflix opens (other than RuntimeBroker.exe).

mfpmp.exe does not stay open. But WWAHost.exe and RuntimeBroker.exe does.

Worth a shot if your VPN does not support adding Windows Apps.

| improve this answer | |
0

You need to add C:\Windows\System32\WWAHost.exe to your VPN exception list. Because Netflix is a UWP app thus WWAHost.exe is used for networking.

Note: Any apps that use WWAHost.exe will be affected as well.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.