0

I can't get Excel to leave my numbers alone. I've set my column to "Text" in the format settings, but nothing I do in the number or other formatting is having any effect. It's been going on for a couple of days now, and I'm losing valuable time trying to get it to stop.

I'm importing 1700+ identifier numbers, with intermittent hyphens, for a range of books going into a database. I need to manage these numbers in a way that requires they stay exactly as they are: no leading zeros removed, none converted to dates, etc. They need to stay exactly as imported. This is a sample of what they look like before import:

00-4
000-9
01-1
001-7
002-5
003-3
3-536-3

Even when I format the column to Text, which is supposed to leave all numbers alone, the "01-1" in this list will paste as the date "1-Jan", as will all others throughout this 1700+ that resemble a date structure. I really need to get this work done and can't if Excel won't allow me to use my numbers as basic numbers. I've wiped my preferences and reinstalled Excel, but it still does it.

I'm using Excel for Mac, Office 365 Subscription, Version 16.27. Hoping there's a solution for this.

Example

1
  • You must import data into existing or new worksheet instead of importing file.
    – Akina
    Jul 24, 2019 at 11:22

1 Answer 1

0

Step 1: Set the celltype to text before pasting

Step 2: In the contextmenu, choose 'paste special' and choose to paste as Unicodetext

Example from my view

Result

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.