0

I'm new to SCCM and have been setting it up in a dev environment available to me. Every machine is virtual and is isolated on its own VLAN (servers and clients alike).

When I try to PXE boot any machine (BIOS or UEFI), initially the TFTP transfer seems to be going well, until usually a few seconds in when I get this error screen:

I get this error screen]

After some time looking at logs and confirming the server was finding a collection for the device in question, I ran a wireshark capture in case that showed anything. Each time the transfer fails, its on a different packet but they all have this one thing in common:

this one thing in common:]

  1. The client sends two acknowledgements
  2. The server attempts to send the next packet
  3. An error is thrown to the client
  4. A number of acknowledgements are made for the new packet by the client that the server does not respond to.
  5. The client stops sending acknowledgements and shows the error screen I linked earlier

The following files are always successful: wdsnbp.com, pxeboot.com, bootmgr.exe, boot.bcd, wgl4_boot.ttf, boot.sdi. The error always occurs when transferring my actual boot.wim file, but only after quite a few packets were successfully sent/received.

Anyone have any thoughts on why I could be running into an issue like this?

SCCM Current Branch, Windows Server 2019.

0

Turns out the July patches are responsible for this issue. Mitigation can be found here: https://support.microsoft.com/en-us/help/4512816/devices-that-start-up-using-preboot-execution-environment-pxe-images-f

Personally, using the PXE Responder instead of WDS worked best for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.