0

My laptop is running on Windows 10 version 1903. I installed this version last week and I am sure this issue comes after 1903 is installed, previously version 1803 & 1809 I have no such problem at all. It stays undetected until today I was trying to communicate with my gaming friends on Discord and found out my mic isn't working properly. After further investigation I realize something is wrong with the system configuration (software issue), the mic issue is not solely on Discord. I googled for almost an hour, literally went through 10+ articles (90% of their methods are similar) and tried out every single possible fix. Finally ended up none of them works. Someone please save me, I am so lost right now.

What I have tried:

  • Make sure the earphone I am using is functional, both I/O.
  • Make sure my laptop's audio port is functional.
  • Make sure my single-jack earphone cable is properly plugged in the single earphone port. No splitter & converter used.
  • Settings > Privacy > App permissions (Microphone), make sure "Allow apps to access your microphone" is on.
  • Device Manager > Audio inputs and outputs, both Microphone Array (Realtek High Definition Audio (SST)) and Speakers (Realtek High Definiton Audio (SST)) make sure they are neither disabled, malfunction nor outdated.
  • Device Manager > Sound, video and game controllers, both Intel(R) Display Audio and Realtek High Definition Audio (SST) make sure they are neither disabled, malfunction nor outdated.
  • Uninstall and reinstall specified drivers above.
  • Control Panel > Hardware and Sound > Sound > Communications tab, check "Do nothing" for "When Windows detects communications activity:".
  • Control Panel > Hardware and Sound > Sound > Recording tab > Microphone Array properties > Levels tab, make sure my default mic is not muted, and volume set to max. In Advanced tab, disabled "Allow applications to take exclusive control of this device" to prevent intrusive app to take control over system settings. In Enhancements tab, tick "Disable all sound effect" instead of "Immediate mode". In addition to this, make sure Microphone Array is set as default.
  • Run Troubleshooter for Sound to check both drivers (Microphone Array & Speakers), no issue detected.
  • Restart Windows Audio in Services.
  • Run SRC Scan. Not sure if this action is relevant however, it resulted in some files are corrupted and unable to fix. I briefly went through the log file and it is likely referring to recent Windows Defender Definition Update. I personally think this has nothing to do with my mic issue here.
  • Tried with every single option (Mic in, Speaker out, Headphone, Headset etc) when earphone is plugged in and a small window pops up. Headphone is chosen by default, and works properly under normal circumstances but not this time.
  • Make sure no pending system update, checked for 10x times.
  • Refer to official Microsoft support article in accordance with sound problem: Fix sound problems in Windows 10. Nothing useful.
  • Clean restart after every single action above taken.

I keep testing the mic in this window after every method tested and none of the fix above helps, the bar doesn't responding in green as supposed. I have LITERALLY no idea what is bugging the mic from working properly. This issue is way harder to fix than no sound issue, which previously fixed by myself for a few times.

enter image description here

0

I have found a report claiming that the latest driver from Realtek that Windows installs (5/22/19 release) is problematic. It was claimed that the audio driver released in January 2019 is the one that works.

Try this :

  • In Device Manager enter the Properties of your Microphone (which is what device?)
  • In Details tab, note and report here the value of the property "Driver version"
  • In Driver tab, click Roll Back Driver if enabled and test
  • If disabled or the above did not help, uninstall the audio device together with its driver, unplug mic, and reboot the computer.
  • I believe the Mircrophone Array (Realtek High Definition Audio (SST)) is the in-charge mic driver. Its version is 10.0.18362.1 (Date 18/3/19). Roll Back Driver is unavailable. Reinstall is not helpful. – Boosted Nub Jul 26 at 3:20
  • My driver is same version and works. You are sure you are looking at the right mic device? – harrymc Jul 26 at 5:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.