0

I have windows 10, updated to 1903 a few days ago. I have the Asus z170 motherboard and have three Hard drives, one an SSD which has my windows installed on it and another one is 1tb Seagate and another 1TB Western Digital drive.

I am getting the "SMART Failure Predicted" message for the Seagate drive.

After looking up the error message up the web, I believe that my drive is at the end of its life. And I have copied all the important data on a separate drive.

I ran chkdsk /f /r but am still getting the message at boot.

Any way to disable this message at boot, as I have to press F1 and then select my SSD to boot every time.

I have my SSD as my primary drive to boot but still, it prompts the error message and loads up the bios.

UPDATE: I plan to replace the drive ASAP, but I want to use the drive with data that I can afford to lose if the drive fails. In other words, I have my data backed up and do not care about this drive. So can I disable the message only for this drive?

enter image description here

3
  • 1
    Replace the failing drive and the message will disappear. You don't want to disable this check as it's very important. – NiallUK Aug 1 '19 at 13:15
  • @NiallJones Yes, I will replace the drive. But, I plan to use the drive and have data on it that I can afford to lose, is there a way to disable the message for this particular drive? – krv Aug 1 '19 at 13:49
  • 1
    No there is not. – Moab Aug 1 '19 at 13:53
2

Some disk tests have shown that some disks can do double or triple their estimated lifetime, so you can ignore this message, assuming that you are prepared for the worse.

As the error arrives in the BIOS, try to disable SMART in it. This is not recommended, but as long as you are prepared for disk failure, you may try it.

Boot into the BIOS and look for a menu titled "Hardware", "Hard disk" or something similar, and any option in it that references "S.M.A.R.T.". Highlight the "S.M.A.R.T" option and set it to "Disabled" or "Off".

It is still recommended sometimes to undo this and verify the SMART data. Some utilities may be able to read the SMART data of the disk even if the BIOS won't do that any more.

2
  • I am not seeing any option to disable bios. I have the ASUS UEFI bios v 1102. That is what I am looking for but can't find such an option. – krv Aug 2 '19 at 5:11
  • There seems to be an option in Advanced mode called SMART Self Test. – harrymc Aug 2 '19 at 7:42
1

Run an actual S.M.A.R.T test to determine the exact issue with the drive; Windows doesn't have standalone software with the smartctl binary, so use a Linux LiveUSB with the ability to install binaries via a package manager:

  1. Follow Ubuntu's guide to Create a Bootable USB Stick on Windows
  2. Boot the LiveUSB → Try Ubuntu without Installing
  3. Once at the Ubuntu desktop, open a Terminal via Ctrl+Alt+T
    1. sudo apt-get update && sudo apt-get install smartmontools
      
      • Press Y to install:
        A Postfix package configuration menu will pop up, choose: OkNo configuration
    2. Where sdb is the Seagate drive: (List all drives: ls /dev | grep sd or lsblk)
      sudo smartctl -a /dev/sdb
      
      • Vendor Specific SMART Attributes with Thresholds:
        ID# ATTRIBUTE_NAME          FLAG     VALUE WORST THRESH TYPE      UPDATED  WHEN_FAILED RAW_VALUE
          9 Power_On_Hours          0x0012   043   043   000    Old_age   Always       -       24972
        194 Temperature_Celsius     0x0002   187   187   000    Old_age   Always       -       32 (Min/Max 16/46)
        
          1 Raw_Read_Error_Rate     0x000b   100   100   062    Pre-fail  Always       -       0
          5 Reallocated_Sector_Ct   0x0033   100   100   005    Pre-fail  Always       -       0
          7 Seek_Error_Rate         0x000b   100   100   067    Pre-fail  Always       -       0
        191 G-Sense_Error_Rate      0x000a   100   100   000    Old_age   Always       -       0
        196 Reallocated_Event_Count 0x0032   100   100   000    Old_age   Always       -       0
        198 Offline_Uncorrectable   0x0008   100   100   000    Old_age   Offline      -       0
        199 UDMA_CRC_Error_Count    0x000a   200   200   000    Old_age   Always       -       0
        223 Load_Retry_Count        0x000a   100   100   000    Old_age   Always       -       0
        
      • Error output will resemble:
        ATA Error Count: 2
        
          CR = Command Register         [HEX]
          FR = Features Register        [HEX]
          SC = Sector Count Register    [HEX]
          SN = Sector Number Register   [HEX]
          CL = Cylinder Low Register    [HEX]
          CH = Cylinder High Register   [HEX]
          DH = Device/Head Register     [HEX]
          DC = Device Command Register  [HEX]
          ER = Error register           [HEX]
          ST = Status register          [HEX]
        
        Error 2 occurred at disk power-on lifetime: 403 hours (16 days + 19 hours)
          When the command that caused the error occurred, the device was active or idle.
        
          After command completion occurred, registers were:
            ER ST SC SN CL CH DH
            -- -- -- -- -- -- --
            40 51 08 28 d5 00 e0  Error: UNC 8 sectors at LBA = 0x0000d528 = 54568
        
          Commands leading to the command that caused the error were:
            CR FR SC SN CL CH DH DC   Powered_Up_Time  Command/Feature_Name
            -- -- -- -- -- -- -- --  ----------------  --------------------
            c8 00 08 28 d5 00 e0 08   1d+10:18:07.310  READ DMA
            ca 00 08 e8 a1 12 e0 08   1d+10:18:06.830  WRITE DMA
            ca 00 08 c8 fa 11 e0 08   1d+10:18:06.830  WRITE DMA
            ca 00 08 00 f7 11 e0 08   1d+10:18:06.830  WRITE DMA
            ca 00 08 b8 f1 11 e0 08   1d+10:18:06.830  WRITE DMA
        
        Error 1 occurred at disk power-on lifetime: 369 hours (15 days + 9 hours)
          When the command that caused the error occurred, the device was active or idle.
        
          After command completion occurred, registers were:
            ER ST SC SN CL CH DH
            -- -- -- -- -- -- --
            10 51 08 10 17 35 e0  Error: IDNF at LBA = 0x00351710 = 3479312
        
          Commands leading to the command that caused the error were:
            CR FR SC SN CL CH DH DC   Powered_Up_Time  Command/Feature_Name
            -- -- -- -- -- -- -- --  ----------------  --------------------
            ca 00 08 10 17 35 e0 08      03:35:59.609  WRITE DMA
            ca 00 08 60 16 35 e0 08      03:35:59.609  WRITE DMA
            ca 00 08 20 11 35 e0 08      03:35:59.607  WRITE DMA
            ca 00 08 08 11 35 e0 08      03:35:59.607  WRITE DMA
            ca 00 08 b0 10 35 e0 08      03:35:59.607  WRITE DMA
        
      • SMART Self-Test Log Structure:
        Num  Test_Description    Status                  Remaining  LifeTime(hours)  LBA_of_first_error
        # 1  Short offline       Completed without error       00%     24885         -
        # 2  Short offline       Completed without error       00%     24765         -
        # 3  Extended offline    Completed without error       00%     24643         -
        # 4  Extended offline    Completed without error       00%     24523         -
        
    3. Run a Long S.M.A.R.T test: (will take several hours)
      sudo smartctl -t long /dev/sdb
      
      Periodically check progress via:
      sudo smartctl -a /dev/sdb | grep "progress" -i -A 1
      
    4. Once S.M.A.R.T test is completed, review whether it completed without error:
      sudo smartctl -a /dev/sdb | grep "Extended offline"
      

  4. Once booted to Windows, run the following for each partition on the drive:
    ChkDsk <DriveLetter>: /OfflineScanAndFix
    


Depending on the results of 3.2 and 3.4, the drive may need to be replaced, but it depends on the S.M.A.R.T test and what precise values are out of acceptable range.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.