2

I hit Ctrl-D in WSL (Ubuntu 18.04) and the window closed. Now when I try to re-enter WSL, I get a blank window with a flashing cursor and nothing else. Ctrl-C closes the window, and Ctrl-F pops up a Windows "Find" window; nothing else registers. How do I resurrect WSL?

Update Win10 was doing an update at the time, so once that was complete I had to reboot the computer. WSL opened fine, so I thought all was well. I should have tried closing and reopening it at that time, but I didn't. Unfortunately, the problem still exists.

  • Check if windows is currently installing an update. Restarting Windows should help. Ctrl+D is a perfectly valid way to exit WSL, it should not be happening – Carlos Rafael Ramirez Aug 2 '19 at 12:57
  • 1
    Thank you, Carlos. It was installing an update. If you would change your comment into an answer, I'll mark it. Thank you for your help! – granti128 Aug 2 '19 at 21:47
  • I am sometimes afraid to put an answer where my solution is not a direct fix for the question, to avoid negative points. ;-) – Carlos Rafael Ramirez Aug 3 '19 at 21:10
  • Carlos, I understand. – granti128 Aug 4 '19 at 3:30
  • 1
    I'm not using an Insider version. I didn't realise there are settings in "Apps & features". Under "Reset" I've clicked the first option, "Repair". It's working for the moment. If I have any further problems, I'll try that again. I see there's also a "Reset" option below "Repair". If ever it gets to the point when even that doesn't work, I'll use the "Uninstall" option and then re-install. ¡Muchas gracias! – granti128 Aug 5 '19 at 5:13
0

Check if Windows is currently installing an update. Restarting Windows should help.

Ctrl+D is a perfectly valid way to exit WSL. It should not be happening.

Sometimes killing the init process will help to start a new WSL session cleanly.

Regards

  • Carlos, unfortunately I have to uncheck your answer because the updates completed and the problem still there. It runs fine the first time after I reboot, but closing it and trying to reopen it doesn't work. Sorry :-( – granti128 Aug 4 '19 at 19:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.