I'm encountering a strange problem on my W10 computer, for a few days my arrow keys have been "driving" my mouse pointer. Pressing the left arrow key will move the pointer a few pixels left, etc.

The first thing that came to my mind was "Oh well, I must have enabled Mouse Keys inadvertently". But Mouse Keys use the numpad and even then, it's not enabled. Rebooting doesn't help, but I've noticed it doesn't happen if the current window is ran as another user (Administrator) or if it's the Task Manager, which suggests the event filter that's catching the key press events is only active on my UID.

I've tried killing various processes but I'm running out of ideas. Could someone suggest some fix for this strange behaviour?

  • @harrymc After reading about the stupid bug of MS Paint below your comment/question (even though truly natural) made me laugh. In some sense, Safe Mode is another bug of Microsoft. Mar 16, 2021 at 11:54
  • Sometimes pressing F7 undoes this mode of the cursor-via-keys.
    – harrymc
    Jul 15, 2021 at 14:04
  • 3
    TL;DR Close all the instances of the Paint Programs, See the magic! Jan 18, 2022 at 22:10

1 Answer 1


Tried killing all running processes on my PC till the problem went away and I can now say for sure the culprit was...

Microsoft Paint

(classic Win32 one)

Apparently it's got a feature that allows moving the mouse pointer using arrow keys, and for some reason sometimes it doesn't stop listening when the window loses focus, so Paint was running in the background since I often use it and it was still doing its job of moving the mouse.

This also explains why the problem can persist after a reboot: when you reboot Windows while Paint is running, Windows will automatically "save your work" and reopen Paint at system boot, causing the bug again!

  • 91
    I'm glad this website exists! I didn't think I'd find the answer this quick. Sep 3, 2019 at 22:11
  • 23
    Thank you soooooo much, that answers the question why mouse cursor only moves on some strange small square. And seems it occurs only when you have several MSPaint running and wake up your laptop from sleep several times.
    – Leo Li
    Sep 9, 2019 at 3:14
  • 10
    (In my case) I guess Paint was open before my crash. After the crash, when windows recovered what it could of my session, this was suddenly happening. Closing Paint worked for me too. Thanks!
    – Regular Jo
    Sep 13, 2019 at 16:15
  • 51
    Happens if the paint was automatically reopened after a forced update! Jun 12, 2020 at 9:46
  • 6
    I was incredulous at first, but killing ms paint worked. So this is still an issue in Feb 2021.
    – Navin
    Feb 23, 2021 at 0:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .