26

I'm encountering a strange problem on my W10 computer, for a few days my arrow keys have been "driving" my mouse pointer. Pressing the left arrow key will move the pointer a few pixels left, etc.

The first thing that came to my mind was "oh well, I must have enabled Mouse Keys inadvertently". But Mouse Keys use the numpad and even then, it's not enabled. Rebooting doesn't help, but I've noticed it doesn't happen if the current window is ran as another user (Administrator) or if it's the Task Manager, which suggests the event filter that's catching the key press events is only active on my UID.

I've tried killing various processes but I'm running out of ideas. I'm fairly sure it's a dumb issue but it's been driving me nuts.

  • Does it happen when booting in Safe mode? – harrymc Aug 3 at 14:43
63

Tried killing all running processes on my PC till the problem went away and I can now say for sure the culprit was...

Microsoft Paint

(classic Win32 one)

Apparently it's got a feature that allows moving the mouse pointer using arrow keys, and for some reason sometimes it doesn't stop listening when the window loses focus, so Paint was running in the background since I often use it and it was still doing its job of moving the mouse.

  • Please mark your answer as best answer. Good job finding the culprit. – DrZoo Aug 4 at 9:02
  • 1
    I'll do after two days, the button is not enabled yet – zdimension Aug 4 at 11:21
  • 5
    I'm glad this website exists! I didn't think I'd find the answer this quick. – Hamid Heydarian Sep 3 at 22:11
  • 4
    Thank you soooooo much, that answers the question why mouse cursor only moves on some strange small square. And seems it occurs only when you have several MSPaint running and wake up your laptop from sleep several times. – Leo Li Sep 9 at 3:14
  • 1
    (In my case) I guess Paint was open before my crash. After the crash, when windows recovered what it could of my session, this was suddenly happening. Closing Paint worked for me too. Thanks! – Regular Joe Sep 13 at 16:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.