0

I've read up on the majority of articles about this "problem" that Microsoft introduced, including their own articles on the reasoning:

https://support.microsoft.com/en-nz/help/4034314/smbv1-is-not-installed-by-default-in-windows https://support.microsoft.com/en-us/help/4046019/guest-access-in-smb2-disabled-by-default-in-windows-10-and-windows-ser

The downside seems to be that Windows itself doesn't recognise this security change. That is, if I share one of my local folders by using the Give access to... Specific People option from Windows Explorer, then when I map a network drive to that shared folder and try to connect, I get the "Error Code: 0x80070035. The network path was not found" message.

Interestingly, when I tried to map a network drive to my own share, but say to Connect using different credentials, I first get a pop-up to "Enter network credentials", which is defaulted to my domain account, and I then get a second pop-up to "Connect to PC", which seems to be after a local account.

Even after entering the credentials of the local account used when Windows 10 was installed, I still get the "Windows cannot access \\pc\share" Network Error.

What is really strange about all this is the known temporary workaround, which is to go to the network adapter and turn off/on the File and Printer Sharing for Microsoft Networks feature, which works perfectly fine until the next time I reboot my PC.

After applying the temporary fix, if I run the PowerShell command Get-SmbConnection, all the network connections I have to the domain servers are either dialect 2.1 or 2.0.2, and the ones to my own PC are 3.1.4.

The common answer to resolving the 0x80070035 error is to turn on the AllowInsecureGuestAuth flag, or to enable the "SMB 1.0/CIFS File Sharing Support" in Windows Features, but that is not something I wish to do. Guest access and SMB 1.0 were turned off for a good reason, and as has been shown, the network shares on my own PC are using SMB 3, so I'm at a loss as to what the permanent fix is.

I'm running Windows 10 Pro 1803 OS Build 17134.376.

  • Is there a reason you have not installed a single cumulative update in over a year? Your issues might be connected to that fact. I seem to recall issues with SMB on 1803 in the last year that were fixed. – Ramhound Aug 5 at 0:18
  • @Ramhound. The reason may be that the enterprise WSUS is not updating workstations as it should. I will look into that. – SiBrit Aug 5 at 3:08
  • Typical Windows Update flakiness. I look at it and it says "You're up to date". Go to View update history, and "Feature update to Windows 10, version 1809", "Failed to install on ‎18/‎01/‎2019 - 0x8024200d". I despair sometimes. Will need to perform a manual download and install to see if it resolves my network problem. – SiBrit Aug 5 at 3:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.