Recently I've got a problem with making bootable USB sticks. When i want to write some OS (Windows or CentOS) image on USB stick with Rufus sometimes i get this kind of error:

Chosen device is being used by another process. Please, close the process before using this device.

[006880] C:\Windows\Explorer.EXE (r)

It's seems that Windows thinks that my device is ready to play at some point and tries to mount it or something. Why Rufus can't block this device while using it? It is really annoying to close explorer.exe every time i need a bootable usb stick.

  • @Ramhound Explorer isn't being blocked from running, Rufus is unable to garner exclusive access to the USB drive because Explorer has access to the drive. DenisNovac, disable exclusive access via the key combo mentioned by Akeo below
    – JW0914
    Aug 6, 2019 at 13:31
  • @JW0914 - I didn't say that File Explorer was being blocked by Rufus, I was trying to indicate, that if any software attempt to close and then prevent File Explorer from restarting wouldn't be legitimate software (restarting File Explorer on the user's behalf is legitimate behavior though).
    – Ramhound
    Aug 6, 2019 at 13:44
  • 2
    @Ramhound How does that apply or pertain to the question asked by DenisNovac? Rufus is a legitimate application with a legitimate purpose and is definitely not malware. It appears you may be taking the error message by Rufus out of context... Do you know/understand why the error was populated?
    – JW0914
    Aug 6, 2019 at 14:02
  • I'm not sure why I can't give a proper answer, but for me, it was faulty USB thumb drives. Coincidently, I came across the following earlier in the day. Probably explains why 2 thumb drives were faulty: truenas.com/blog/sata-doms-over-usb-drive
    – woter324
    Mar 7, 2022 at 18:06
  • 1
    downloading the latest version of rufus resolved the issue for me Apr 26, 2023 at 10:34

4 Answers 4


Rufus developer here.

Why Rufus can't block this device while using it?

Well, we try to do just that, with exclusive access, but Windows doesn't exactly play nice.

For instance, what most people don't know is that Windows (e.g. VDS) won't let you clean up the existing partitions of a physical disk unless you have unlocked that disk first... which is very counter-intuitive and means that, during that time, there's no way of preventing other applications from accessing that disk.

In short, Rufus very much tries to lock both the physical disk and logical volumes as required, but it isn't always as logical as one expects. Another example of it is that, to get a newly formatted volume recognized, Windows also forces you to dismount the volume (as per the notes here), which means that, even if you acquired a lock on the volume, you have no choice but to relinquish it to keep Windows happy. Therefore, whereas there are many instances where Rufus would like nothing more but to keep a lock to the drive to prevent external interferences, Microsoft have designed their OS in such a manner that we can't do that, which of course opens the door for the kind of problem you observed.

Just note however that, according to your message, it is unlikely that it is actually explorer.exe itself that is the issue, as the (r) you see means it's only requesting read access, which shouldn't prevent Rufus from getting exclusive access to the volume. Most likely the actual conflict comes from one of the internal Windows processes or services, that are high level enough that they can't be listed (while Rufus tries to help by listing the processes accessing the drive, there's only so much it can do against Windows privileged processes, which are incredibly hard to enumerate). Most likely, you'll want to check that you aren't using one the the applications that is listed at the end of the Rufus FAQ, as some of these are known to be a bit too trigger happy with accessing volumes that they shouldn't be accessing when they have no business to do so.

Alternatively, since ironically your issue is likely the result of Rufus not being able to "block this device while using it" (by not being able to obtain the exclusive lock it requests to keep other applications at bay), you may want to press Alt-, (that's the Alt and comma keys) in Rufus, so that it won't try to lock drives.

Of course, if you do so, then there is always a risk that whatever other process is also trying to access said drive might modify it at the same time as Rufus is performing its operations, which could result in corrupted data or an unbootable drive (which is the precise reason why Rufus requests an exclusive lock by default)...

Hope that helps.

  • disabling exclusive lock worked for usb Dec 11, 2020 at 3:07
  • 3
    it would be nice if rufus would at least to retry rather than just failing at this point.
    – Al Ro
    Dec 12, 2022 at 1:53

I solved this problem on my computer by doing these 3 things (I think the first one is the one that fixed it... but the others might also be necessary).

Disable the Windows 10 feature that automatically opens USB drives in Explorer, temporarily. The drive was opening over and over again in explorer, which matches the problem pretty clearly...

  1. Start menu
  2. Control Panel
  3. Hardware and Sound (if you're not using Category view, you won't see this, go to step 4)
  4. Autoplay
  5. Removable drive: change "Open folder to view files" to "Take no action"

If you are running Google Drive, Close Google Grive. It kept asking to back up the usb drive while it was being written.

  1. right click the google drive icon in the notification area of the taskbar.
  2. Click the gear icon
  3. Click Quit

I'm also running Avira anti-virus, (edit: which is listed as incompatible by Rufus). Temporarily turn off Avira real-time protection for 10 minutes while running Rufus. This step on its own didn't fix the problem, so I'm not sure it's even necessary as long as you do the previous 2 steps.

  1. right-click the Avira icon in the notification area of the taskbar.
  2. "Turn off real-time protection..."
  3. 10 minutes

The tip to press Alt + , didn't solve the problem for me.

If your USB got corrupted, you might need to reenable the "Open folder to view files" option in order to get windows to give you the "there's a problem with this drive, do you want to fix it?" popup. Re-disable the option once the drive is fixed and you want to try to write to it with Rufus again.

  • Just so you know, Avira is explicitly listed as incompatible software in the Rufus FAQ.
    – Akeo
    Jan 12, 2023 at 13:47
  • 3
    Disabling "Automatically open USB drives" 100% fixed my issue.
    – Phoenix
    Feb 28, 2023 at 20:28

My Rufus page was doing the same thing (that's how I found this site).

But I think I figured it out: In the Boot Selection you can hit the select button then select your file, but if you had put your file that you're trying to boot in the USB that your using then it won't work.

I don't know if that helps, but we had the same problem and this is the answer I thought of.

Hope this help's you out. :-)

  • If you put an image inside the USB and then try to write it on the same USB through Rufus - Rufus will format the USB first and then there will be no more image inside.
    – DenisNovac
    Nov 5, 2020 at 8:40

I had such issue, that each time I tried to run Rufus it failed to have full access to the pendrive. It helped to kill all unnecessary apps - but I guess it was Avira antivirus. ;)


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .