0

My Windows 10 laptop has been experiencing a weird issue where the Wifi connects but I cannot access the Internet. When it starts, there's nothing I can do but restore Windows from backup or re-install Windows.

nslookup on Command Prompt works fine, I get DNS name resolution. But, ping or web browser or anything fails to resolve a DNS name. They sit, wait, and timeout with a DNS resolution error.

Tried flushing the DNS cache, re-installing the network driver, resetting the winsock driver, flushing the route table, re-connecting to wifi, specifying static DNS server IPs, switching Wifi networks, tethering through my phone, and rebooting. Nothing works.

Doubt it's a hardware issue, since re-installing Windows or restoring from a recent backup fixes the issue... at least until it happens again a few weeks/months later. Also tried disabling the onboard Wifi and plugging in a separate USB wifi adapter, same result.

Anyone have any thoughts? What would cause, and how to fix?

I've been making frequent full-system backups in the event this occurs again, I restore from backup and all is fine. Only thing I can think that changed around the time the issue began was I got a displaylink USB hub/display adapter for a third monitor.

| improve this question | | | | |
  • Try another OS as a test, for a while. Run Ubuntu from a USB drive the next time connection fails, to confirm that it is OS and not HW. – DrMoishe Pippik Aug 7 '19 at 3:21
  • Thanks for your comment. I'm pretty sure it's not the hardware because yes, booting to another OS works fine. If I boot to Windows "safe mode (with networking)" it works fine. Boot back into Windows, and nslookup works but everything else fails to resolve DNS. If I re-install Windows or restore from a recent Windows backup, everything works again, until the next time it happens. – Crash Override Aug 7 '19 at 15:22
  • Does reinstallation from MS ISO, made with the Media Creation Tool, pose the same issue? Could it be a failed malware installation that is stuck in both the disk image and on the machine? Try a single (not permanent) malware scan with an alternative tool, such as Kaspersky Security Scan. – DrMoishe Pippik Aug 7 '19 at 16:53
  • Reinstalling Windows from scratch (from the Media Creation Tool) fixes the problem. Also, restoring from a backup fixes the problem. I have tried Antivirus and spyware scans, but not Kaspersky. – Crash Override Aug 7 '19 at 19:08
  • 1
    Windows 10 v. 1903 appears to be a work-in-progress. v. 1809 appears to be reasonably stable, at this time, and if you have continued difficulties, stick with that 9or earlier) versions. – DrMoishe Pippik Sep 1 '19 at 1:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.