-2

I have setup openSSH server in my workstation running windows 10 with username domain\user. But when I try to ssh into my system from my home mac I get an error 'Connection reset by port 22'.

As the username contains escape character(), I tried using these combinations 1. ssh domain\username@ip 2. ssh 'domain\username'@ip 3. specified username in ~/.ssh/config file

1
  • Did you test it using a GUI client to check if it is a problem on client-side (passing the backslash correctly to ssh) or server-side (correct format of the username for the server)? Aug 7, 2019 at 7:55

1 Answer 1

-1

If you want to use the escape character, you have to type "\\" (i.e. the escape character twice)

2
  • tried using ssh domain\\user@172.26.90.87...getting error domain\\user@172.26.90.87's password: Permission denied, please try again.
    – debapam
    Aug 7, 2019 at 7:44
  • You might want to check out this question: superuser.com/questions/543626/…
    – marijnr
    Aug 7, 2019 at 8:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.