I have a master modem router (Netgear N300) and a slave router (Linksys WRT1900ACS).

When I connect master LAN to slave WAN via ethernet any devices connected to the slave do not get any internet connection.

When I connect master LAN to slave LAN any devices connected to the slave do get internet, but when I look at connection info I see they are connecting through the master router. This is not what I want. I want it to connect through the slave router.

I am not network expert but my understanding was that the right setup is master LAN to slave WAN. If that's the case, why is the slave not getting any internet connection but works fine LAN to LAN?

Some info on each:

  • Master is on DHCP range from to
  • Slave is on DHCP range from to
  • You should check here. The long and short of it is that consumer grade firewalls are not intended to be configured this way and you will have problems with it. – Cliff Armstrong Aug 7 '19 at 16:55
  • Double NAT may be bad, but it works. Are you sure the innermost router is actually set up correctly? It may be trying to dial a PPPoE modem or whatever. It needs to do DHCP. – Daniel B Aug 7 '19 at 16:56

It sounds like your "slave router" probably has NAT (NAPT) or at least IP forwarding enabled, so it's not just acting as a switch and transparently bridging between WAN and LAN. It's actually acting as an IP-layer router between WAN and LAN. If that's the case, it needs to have two separate IP subnets out WAN and LAN. So if you want to use the subnet on its WAN side, you need to use a different subnet, say on its LAN side.

It sounds like you're currently trying to use on both sides of that router, which means it won't know how to route packets to 192.168.0.x addresses; should it send them out its WAN port, or its LAN port? There's no good way to know, so it chokes.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.