1

I tried to open a session on msfconsole but it gives me an error:

"Exploit was completed, but no session was created."

0

More context is always useful, but according to this page in Rapid7's KB:

The "no session was created" message occurs if one of the following happens:

1. The exploit you use doesn't work against the target you selected. Could be the
   exploit is for a different version, there is a problem with the exploit code, or
   there is a problem with the target configuration.

2. The exploit you use was configured to use a payload that doesn't create an
   interactive session. In this case, the framework has no way of knowing
   whether the exploited worked, because it doesn't receive a connection from the
   target when its successful (for example, running notepad).

If you try the reverse payload, get that message, and the target service doesn't
crash, make sure your target settings are correct, and that the target system is
running the right version of vulnerable software.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.