20

My desktop environment/window manager (XFCE) in Debian has sadly, suddenly started asking me if I'm sure I want to copy/paste into my terminal.

Yes. I'm sure, always.

How do I disable this fantastical technology, with XFCE specifically? Debian 9.9, if it matters.

3 Answers 3

23

This is new "feature" of xfce4-terminal.

Go to Edit > Preferences > General tab and uncheck "Show unsafe paste dialog".

2
  • 2
    It looks like the unsafe past dialog was just implemented in Xfce Terminal v0.8.8, which was very recently released.
    – fixer1234
    Aug 9, 2019 at 1:09
  • 6
    Well, I hope it got the "retarded feature of the year" award. Aug 16, 2019 at 2:10
1

Another answer here explains how to handle this issue through the GUI. However, if you need to do it in a script or from the terminal itself:

echo "MiscShowUnsafePasteDialog=FALSE" | sudo tee -a /etc/xdg/xdg-backbox/xfce4/terminal/terminalrc
5
  • 2
    Your approach changes the system-wide settings. Perhaps it would be better to show how to change the setting within the user's account (like the other answer does, but through the GUI)
    – roaima
    Dec 2, 2020 at 14:05
  • I tried the user-specific location in a test machine: /home/%USER/.config/xfce4/terminal/terminalrc with mixed results.
    – bfbcPing
    Dec 2, 2020 at 14:28
  • Mixed results maybe because %USER isn't a valid value? You could try sed -i '/^MiscShowUnsafePasteDialog/s/=.*/=FALSE/' "${XDG_CONFIG_HOME:-$HOME/.config}/xfce4/terminal/terminalrc", which will update the MiscShowUnsafePasteDialog value. Unfortunately it won't create it if the entry is missing, and I don't have a copy of the terminalrc with which I can test a foolproof suggestion
    – roaima
    Dec 2, 2020 at 15:02
  • I mistyped the % instead of $. The issue is that the terminalrc doesn't seem to be copied to the user's profile automatically. I think it is generated when there are changes made in the GUI. I haven't been able to test just copying the /etc/xdg/xdg-backbox/xfce4/terminal/terminalrc to the profile location and making changes there. For my purposes, a global change is acceptable, and it took forever to come up with this solution. I figured I'd put it here for the next person googling to try and find the answer.
    – bfbcPing
    Dec 2, 2020 at 15:13
  • Sounds good to me. Thank you!
    – roaima
    Dec 2, 2020 at 15:42
0

It is year 2022 now and the Edit > Preferences > General (tab) > "Show unsafe paste dialog" is no longer present.

However, Edit > Preferences > Advanced (tab) has checkboxes related to copy & paste via mouse, for those of us missing the old X-Window/XTerm/PuTTY behavior:

  1. Use middle mouse click to close tabs
  2. Use middle mouse click to open URL
  3. Automatically copy selection to clipboard.

Terminal Preferences (Advanced tab)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.