As suggestions for attempts to solve the problem grew, I will start with a summary of what didn't work to make it easier to read the original article below:

  1. That's my current hardware specifiations
  2. Windows boot screen stays more than 1 minute to then display the login screen
  3. Initially, I had just one Windows 10 x64 installation, then I installed a new Win10 on dual boot to compare
  4. After the new win10 dual boot installation, the boot time was reduced to 8 seconds (in this case the default win10 was automatically set to the new installation)
  5. But changing to default win10 startup to the old win10, the time came back to 1 minute
  6. Both win10 are with Fast Startup OFF
  7. Safe boot doesn't change the boot time
  8. The red led in front of the desktop (disk I/O) is completely OFF until the login screen is reached (so, no disk I/O during 1 minute)
  9. The drivers for BIOS, RAID, Motherboard are the same for both win10 installations, so it's not a hardware or driver problem.

Original Question:

For some reason, a few weeks ago, my Windows 10 is taking over 1 minute to boot. That is, more than 1 minute just in that initial black window with the Windows 10 logo and the little dots circling:

enter image description here

... aside from the time remaining when already logged in ...

And my Windows 10 is on an SSD!

Would anyone know to tell me any program that allows me to audit which process is causing this delay in the boot? I want to find out the villain ...


Following the suggestion in the comments (https://superuser.com/a/1205327/905372), I got the analysis:

enter image description here enter image description here enter image description here

But I can't understand what's the problem.

I also uploaded the result files here.

Could anyone help me with this issue?

Edit 2

Just to confirm, I made another Windows 10 installation in a new partition on my SSD, using dual boot. For the new Windows 10 installation, the startup is IMMEDIATE. For the old Windows 10 installation, the startup is STILL MORE THAN 1 MINUTE.

So, once for all, IT'S NOT A HARDWARE PROBLEM!

Edit 3

After installing the new Win10 partition, Windows created a dual boot (and set the new Win10 as the default system).

In this case, the boot takes 8 seconds to reach the dual boot screen.

But changing the default startup system to the OLD Win10 (as described here), strangely, the boot back to take more than one minute to reach the dual boot screen.

enter image description here

So the problem may be something before Windows itself.

Edit 4

As explained in this comment, Fast Startup is not influencing in this case.

Edit 5

One thing I have not commented on before is that during this minute of waiting, the red LED on the front of my desktop, which accuses disk access, is completely off. That is, there is no disk access for 1 minute.

It is as if the boot is waiting for some signal and only after 1 minute does it "release" itself to start the boot itself...

  • the data show most time is spend on desktop after boot, but in PreSessionInt I see that the Asmedia 106x SATA Controller takes 4s to start.0,7s delay happens when starting the WD drives. So connect the drives to native sata port no, 3rd party controller sata ports – magicandre1981 Aug 9 '19 at 14:21
  • Thanks, but I don't think it's due to physical connections, once the current hardware setup is the same many months ago, but this slowness started weeks ago. Could it be some piece of software? – Rogério Dec Aug 9 '19 at 14:36
  • simply try it. I also see a high CPU usage of kernel because of the Intel storage driver iaStorA.sys in version "" which is old. try a newer driver. Also which ssd do you use? I see a Intel RAID device, so is this SSD using RAID0? – magicandre1981 Aug 10 '19 at 10:39
  • I have 2 Samsung SSD 850 EVO 250GB in Raid 0, which it achieves almost 1 Gb/s in the read test of CrystalDiskMark 6.0.2 x64. You can see my complete hardware configuration here: rogeriodec.com.br/hwinfo.HTM As I said before, the hardware configuration is the same, even before this slowness starts to appear... – Rogério Dec Aug 10 '19 at 14:35

I can't comment, all I can see with the performance log you uploaded is:

<serviceTransition name="XTU3SERVICE" endedAt="-1" firstCheckpointedAt="140581" startedAt="140149" container="unknown" processingTimeDelta="9223371896274" firstCheckpointTimeDelta="432" totalTransitionTimeDelta="9223371896706" transition="start" group="Null"/>

<diskIO totalTime="29205" totalOps="86157" totalBytes="9415775232" medBytesPerWrite="4096" avgBytesPerWrite="654094" writeTime="6857" writeOps="7926" writeBytes="5184355328" medBytesPerRead="4096" avgBytesPerRead="54088" readTime="22348" readOps="78231" readBytes="4231419904">

<serviceTransition name="IObitUnSvr" endedAt="17965" firstCheckpointedAt="17950" startedAt="16582" container="IUService.exe (3852)" processingTimeDelta="16" firstCheckpointTimeDelta="1368" totalTransitionTimeDelta="1384" transition="start" group="Null"/>

<pnpObject type="Device" endTime="4625" startTime="596" name="PCI\VEN_1B21+DEV_0612+SUBSYS_06121849+REV_02\4+23b6d2a4+0+00E3" duration="4029" friendlyName="" description="Asmedia 106x SATA Controller" prePendTime="4029" activity="Enum"/>

Other than this, during boot and reading of BCD seems like there's a 4 GB file being read.

All I can see from this is multiple factors are affecting your boot up speed.

|improve this answer|||||
  • Thanks, but it's not clear for me: what's the problem and how to solve it? – Rogério Dec Aug 13 '19 at 13:31
  • Find the application called Intel® Extreme Tuning Utility and try deleting it. Another tool you can try removing see if it improves is IOBit. Another thing that will delay your boot but should only do so before the machine boots up is your extra SATA3 port card. – ddemuro Aug 13 '19 at 18:02
  • Thanks, I've uninstalled Intel® Extreme Tuning and Iobit. No difference no boot speed. About SATA3, please read the new "Summarize, item 9 on the original question. – Rogério Dec Aug 13 '19 at 20:24

Going through the comments I think I know what the problem is.

Fast Startup, which effectively is Suspend to RAM, with hibernate as backup if RAM content is lost is in use. It looks like each time you boot the system recovers from the hibernate file in stead of the RAM, so it needs to read (and decompress) the hibernate file back into memory.
(Why it does that I don't know. Could be bios settings, could be motherboard not compatible with suspend-2-RAM. Could be some hardware (e.g. video-card) not compatible with it.)

You are using for your system drive an Intel based software raid of 2 SSD drives.
But you are on old drivers for the Intel raid and probably for the motherboard chipset itself as well. Your Bios could be fairly old as well and also be a factor.

I have seen issues before where older Intel drivers combined with a recent Windows 10 build caused bad reading performance in the early phases of the boot-process. And that seems to be exactly your problem.

I would recommend a full refresh of all drivers. Bios, motherboard and Intel RAID. For the latter 2 go for the drivers provided by Intel. Many motherboard manufacturers have really outdated drivers for these on their web-site. The Intel supplied ones are usually a lot newer.
It won't hurt to make sure all other drives (and Bios of the video-card if possible) are up to date as well.

|improve this answer|||||
  • Thanks, but if you read the "Edit 2" in the original question, you'll see that boot speed is ok for the new Win10 installation on dual boot. So, the drivers for Bios, motherboard and Intel RAID are the same to both Win10 installation, even so, the problem persists. – Rogério Dec Aug 13 '19 at 12:26
  • Tonny's first point isn't knocked out by your Edit 2. It's possible your new Win10 installation has fast startup turned off, and so doesn't need to read hiberfile. Boot the slow Win10, and turn off fast startup and hybrid startup, see if it goes back to the speed it should be. Also as for drivers, those aren't shared between OSs, they aren't firmware. While I doubt drivers are the cause, there could be driver differences between your two Win10 installs. – udlp Aug 15 '19 at 16:49

I noticed that CompatTelRunner.exe is one of the biggest CPU eaters in the boot trace log. This is the Windows 10 telemetry which is usually harmless, but may sometimes become bothersome.

I suggest to turn off all options in Settings > Privacy > Diagnostics & feedback. You cannot completely turn off "Diagnostic data", but you may at least set it to "Basic".

It also seems that turning on Fast Startup fixes the problem, so you might consider using it, rather than continuing further with the below methods in this answer.

If that's not enough, here are some articles that list various methods, ordered below from least dangerous to more forceful. I suggest at least creating, before starting, a System Restore point as backup. The articles below may overlap on some methods. Where they suggest deleting anything, I would rather counsel renaming instead, so all the methods are kept as reversible as possible.

Totally disabling telemetry may cause some problems with Windows Update. You will have to stay on the lookout for harmful effects.

If no method suggested by myself or others does fix the problem, and as the new Windows 10 installation does not show this problem, you might reinstall Windows 10 as a solution.

|improve this answer|||||
  • Thanks, I did all your steps, but nothing has changed. I would not want to reinstall Windows 10 because it takes WEEKS until all programs are reinstalled and reconfigured correctly, and a lot is lost. – Rogério Dec Aug 13 '19 at 20:41
  • Did you try another user profile? – harrymc Aug 13 '19 at 20:56
  • This has nothing to do with user profile, because, as I mentioned in the original post, the slowness occurs BEFORE even the dual boot screen appears to choose which windows I want to use. – Rogério Dec Aug 13 '19 at 21:13
  • For a weird problem like that you should try everything possible. Another heavy disk user is Windows Defender - try to disable it (3 methods) for now. Do you see interesting messages in the Event Viewer? If all else fails you might try sfc /scannow and even Startup Repair. – harrymc Aug 14 '19 at 8:42
  • Ok, all done (even these options are affected after login and the problem is before login). Nothing changed. – Rogério Dec Aug 14 '19 at 18:37

Yesterday I installed the last automatic Windows update (KB4512508, KB4508433, and KB2504637) and after this, the slow boot was corrected and the complete boot times were reduced to some seconds again...

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.