1

I need to disable the auto-screen-lock.

I have tried the following methods as suggested in stack-overflow and other sources.

  1. to disable screen-saver lock

gsettings set org.gnome.desktop.screensaver lock-enabled false

2.to disable idle activation

gsettings set org.gnome.desktop.screensaver idle-activation-enabled false

gsettings set org.gnome.settings-daemon.plugins.power idle-dim false

But even following these recommendations the screen gets auto-locked after sometime when my system is started and when i don't interact with the system.

can someone point me what could be the issue, not able to figure out myself.

Thanks.

1

These things worked out for me.

commands applied for turning off auto-lock and keep display on are following

if below commands gives false then set it to true

$gsettings get org.gnome.desktop.lockdown disable-lock-screen
$gsettings set org.gnome.desktop.lockdown disable-lock-screen 'true'

if below command returns true then set it false

$gsettings get org.gnome.desktop.screensaver lock-enabled
$gsettings set org.gnome.desktop.screensaver lock-enabled false

if below command returns true then set it false

$gsettings get org.gnome.desktop.screensaver idle-activation-enabled
$gsettings set org.gnome.desktop.screensaver idle-activation-enabled false

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.