1

I put together a PC with the following components:

asrock x570 pro4
ryzen 5 3600
gtx1660ti
2x8gb ddr4  corssair 3000mhz ram
1nvme ssd (removed as it may not compatible)
1 micron ssd
500W gold certified power supply

when I power on I get no activity on display.

tried so far:

  • reseating ram
  • booting with 1 stick
  • hdmi port on mobo
  • display port on mobo
  • usb stick plugged into usb on mobo and also front panel usb with win10 tool

then removing gpu altogether and repeated the above

  • reseat cpu
  • reset cmos via jumper cap

Is there anything else I can check or try?

0

I had a similar issue, but it only happened when I added a second GPU. I updated the BIOS firmware to th latest P1.40 & it solved my issues.

New contributor
Nunurs is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.