1

I am trying to run glxgears on a remote Linux server using XQuarts 2.7.11 on macOS Mojave (10.14.6), but I get the following error:

libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast

Is this issue due to the fact that the OpenGL version on my MacBook is 2.1, or is it an issue with OpenGL on the Linux seerver?

I need OpenGL 3 or 4 in order to run Unreal Engine on the Linux server.

1 Answer 1

0

There could be a number of causes. First off, if you are using Ubuntu 16.04 as the remote server, try to delete off the mesa version of libGL.so

$ sudo rm /usr/lib/i386-linux-gnu/mesa/libGL.so.1

Basically just look for different versions of libL.so and remove those unneeded or outdated

$ sudo ldconfig -p | grep -i gl.so

If you are using Steam on Linux, there is a specific issue where you need to use libnvidia-compute-418 and libnvidia-gl-418

Note that on some systems, the Mesa version of LibGL might be named something like d /usr/lib/x86_64-linux-gnu/libGLX_mesa.so.0.0.0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.