2

Please see GIF under This is the website where I see this issue. I want stay on current tab. Note I never ticked "When you open a link in a new tab, switch to it immediately".

enter image description here

  • 2
    The page itself could be set to open in new tab. There's nothing you can really do to override that. Some browsers will hover the info at the bottom of the page, so you can see what the behaviour will be for any click or modifier method. – Tetsujin Aug 13 '19 at 9:08
  • 5
    The fact that you have asked basically the same question 4 times for 4 different browsers would reinforce this. Ref: superuser.com/questions/1470585/… & superuser.com/questions/1470598/… & superuser.com/questions/1470563/… – Tetsujin Aug 13 '19 at 9:11
  • 1
    I can't test your specific website because it's throwing out some nasty cookies my browser is set to discard. – Tetsujin Aug 13 '19 at 9:12
6
+50

The HTML of the website is opening the link with the option of target=_blank which causes it to open in a new window or tab (according to browser settings).

You do not need such a complicated website to demonstrate this behavior. This minimal Tryit example is already enough to demonstrate it.

In Firefox this behavior can be disabled by entering about:config in the address bar, then setting browser.tabs.loadDivertedInBackground to true.

For more details see the Mozilla Support article
Can I force a link to open in a non-active tab, instead of changing to that tab?

0

harrymc's answer didn't work. I musted toggle other setting in that link. I put star next to it in screen-shot beneath.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.