24

When trying to open https://www.walmart.com/, both Firefox (v. 68.0.1 in Windows 10, v. 17763.652) and Windows Edge (Microsoft Edge 44.17763.1.0) display the message "Walmart can’t use this browser", with suggestions to try Firefox, Chrome, etc. All browsers were connected through the ISP without proxy or VPN.

N.B. Retried in Edge, **going through a search engine (Start Page), which created the long URL, below, with the referrer tacked into the URL:

https://www.walmart.com/?adid=22222222220220085369&wmlspartner=wmtlabs&wl0=e&wl1=s&wl2=c&wl3=366238633331&wl4=kwd-27665750&wl5=1027028&wl6=&wl7=&wl8=&veh=sem&gclid=EAIaIQobChMI_7KNj9b-4wIVjq_ICh1bzQM3EAAYASAAEgIAT_D_BwE

This opened Walmart's website correctly, both in Edge and in Firefox. Apparently, Walmart would not open the first time without a referrer. Now that it's dropped cookies in the browser, it reopens with or without referrer. Go figure!

Firefox was restarted in Safe mode, and with all extensions disabled. All browsing data was deleted, including cache and cookies, with no better result. The Chameleon extension was installed, and set to emulate other browsers Walmart recommends, with the same issue.

On starting Firefox's Network Monitor (CtrlShiftE) and reloading, the following was shown:

Walmart Network Log

However, the TOR Browser works well on that site, with connection through their anonymizing onion router (no VPN, though).

Is it a security setting or some other issue causing both Firefox and Edge to fail to open Walmart's site?

closed as off-topic by Ramhound, Burgi, Run5k, JakeGould, Dmitry Grigoryev Aug 14 at 11:24

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This question is not about computer hardware or software, within the scope defined in the help center." – Burgi, Run5k, Dmitry Grigoryev
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 3
    What version of EdgeHTML are you using? I have tried every version I have access to and not a single one generated the error in question. – Ramhound Aug 13 at 1:02
  • 1
    I don't think this is problem Super User can answer as your diagnostics suggest the problem is with the destination website rather than your machine. – Burgi Aug 13 at 10:26
  • 7
    Some poor developer at Walmart is about to lose their job... – MonkeyZeus Aug 13 at 12:20
  • 1
    Have you considered shopping at Target? – Z4-tier Aug 13 at 20:40
  • 9
    I just consider it hilarious that Tor can get in, but Edge is unable. Imagine the news reports: "A Walmart spokesman confirmed that their website is written specifically to allow users of the Tor dark-web browser to visit their e-commerce site, but to bar Microsoft Edge. A company spokesman said, "We have very little trouble with Tor users, who are generally knowledgeable and polite. But people who use Microsoft's default products are a nightmare. We've had to block them just to get a little sleep". Attempts to contact Microsoft's Media Support Group for comment resulted in a 404 error". – Bob Jarvis Aug 13 at 21:41
44

Entering https://www.walmart.com/ as the URL does not open until the site has left cookies in the browser. Going into the site from a search engine, with added referrer in the URL, or, as @Spike states, going into a page within the site, such as https://www.walmart.com/tv seems to work, enabling a cookie to be sent to the browser. After that, the root site is accessible.

Apparently, this issue is at Walmart.com, not in the browser. Walmart.com has been notified of the issue by email.

  • Looks like it works for me now (no previous cookies). – EKons Aug 13 at 23:24
6

It's not just Firefox that is having this issue. I've also seen Mac users posting they are also seeing the issue in Safari. I have tried all updated versions of Chrome, Edge and Firefox and all get this error.

If you go to any other page on Walmart's site, like walmart.com/tv, it works and then you can click on the home page icon which brings you successfully to walmart.com. If you go directly to walmart.com without going to another page on Walmart's site, it always fails.

4

I tried using wget. It redirects correctly, but gives a 444 unknown error. In theory the site could be rejecting wget requests, but my money is on this being related. Notice that with this example, it redirected twice.

The problem appears to be with the site, not our browsers.

> wget walmart.com/tv
--2019-08-13 13:11:11--  http://walmart.com/tv
Resolving walmart.com (walmart.com)... 161.170.230.170, 161.170.232.170
Connecting to walmart.com (walmart.com)|161.170.230.170|:80... connected.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: https://www.walmart.com/tv [following]
--2019-08-13 13:11:11--  https://www.walmart.com/tv
Resolving www.walmart.com (www.walmart.com)... 23.201.65.160
Connecting to www.walmart.com (www.walmart.com)|23.201.65.160|:443... connected.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: /cp/televisions-video/1060825 [following]
--2019-08-13 13:11:12--  https://www.walmart.com/cp/televisions-video/1060825
Reusing existing connection to www.walmart.com:443.
HTTP request sent, awaiting response... 444 Unknown
2019-08-13 13:11:12 ERROR 444: Unknown.

Not the answer you're looking for? Browse other questions tagged or ask your own question.